10e0bd1fe0
deafcf9162 ramips: define remapping-range for DAP-X1860 711e45e158 ramips: add support for D-Link DAP-X1860 A1 2a4a6372d3 ramips: lower re305-v3 spi-max-frequency 50d707e344 lantiq: fix lzma-loader for Netgear DGN 3500(B) fea7478f2d iproute2: add missing libbpf dependency b2db4fa956 ath79: tiny: Do not build TPLink WPA8630Pv2 by default c6b6cab858 ramips: mt7621: mikrotik 760igs (hEX S) fix SFP 2faa7ff09e openssl: fix variable reference in conffiles 0636d6b925 ath79: use lzma-loader for Senao initramfs images 70d2e8b4db ath79: Fix glinet ar300m usb not working 9aaeaa8d2a toolchain: musl: Fix symbol loading in gdb 99fddbe4fd wireless-regdb: update to 2023.02.13 f677302cc4 build: fix for sourcing targets image config installed via feeds 50d37b0b37 ramips: rt5350: enable lzma-loader for ALLNET ALL5003 13d3fb3c20 bpf-headers: fix package category 7531ef7f1c sdk: expose PATENTED an NLS build options 4ed98849a5 ksmbd: update to 3.4.7 51cf5aa731 hostapd: add missing return code for the bss_mgmt_enable ubus method d2f3422e9d kernel: filter out pahole version 5030620db6 dnsmasq: add dhcphostsfile to ujail sandbox 066ac40c29 netifd: strip mask from IP address in DHCP client params 354ad1084a lantiq: nand: don't yield while holding spinlock 6035401f46 mac80211: fix invalid calls to drv_sta_pre_rcu_remove fc1750b305 ramips: mt7621: ASUS RT-AX53U add NMBM, nest firmware 85b6a7a195 ramips: Alternative name Asus RT-AX1800U for Asus RT-AX53U a3fbeb2cbb ramips: add missing LEDs to Asus RT-AX53U 21a121af80 uboot-envtools: add support for ramips Asus RX-AX53U 3014c694da ramips: add support for read/write uboot env to Asus RX-AX53U ff22a20922 comgt: ncm: support Mikrotik R11e-LTE6 modem 5909b6c886 comgt: add quirk for Mikrotik modems based on Mikrotik R11e-LTE6 05ec70f6ae kernel: add support for XMC XM25QH64C 541be7ddb2 ath79: Refresh patches
65 lines
1.8 KiB
Diff
65 lines
1.8 KiB
Diff
From: David Bauer <mail@david-bauer.net>
|
|
Date: Sun, 5 Jun 2022 23:43:38 +0200
|
|
Subject: ramips-mt7621: make DSA images swconfig upgradable
|
|
|
|
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
|
|
index c3e2291a9d91bae234707b1d81277b645bdd6920..64e02a53d30b71144ef4158a06c3a791f8d91f90 100644
|
|
--- a/target/linux/ramips/image/mt7621.mk
|
|
+++ b/target/linux/ramips/image/mt7621.mk
|
|
@@ -180,7 +180,6 @@ endef
|
|
TARGET_DEVICES += asiarf_ap7621-nv1
|
|
|
|
define Device/asus_rt-ac57u
|
|
- $(Device/dsa-migration)
|
|
DEVICE_VENDOR := ASUS
|
|
DEVICE_MODEL := RT-AC57U
|
|
DEVICE_ALT0_VENDOR := ASUS
|
|
@@ -1271,7 +1270,6 @@ endef
|
|
TARGET_DEVICES += mts_wg430223
|
|
|
|
define Device/netgear_ex6150
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
DEVICE_VENDOR := NETGEAR
|
|
DEVICE_MODEL := EX6150
|
|
@@ -1284,7 +1282,6 @@ endef
|
|
TARGET_DEVICES += netgear_ex6150
|
|
|
|
define Device/netgear_sercomm_nand
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
BLOCKSIZE := 128k
|
|
PAGESIZE := 2048
|
|
@@ -1467,7 +1464,6 @@ endef
|
|
TARGET_DEVICES += netgear_wax202
|
|
|
|
define Device/netgear_wndr3700-v5
|
|
- $(Device/dsa-migration)
|
|
$(Device/netgear_sercomm_nor)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 15232k
|
|
@@ -1804,7 +1800,6 @@ endef
|
|
TARGET_DEVICES += tplink_tl-wpa8631p-v3
|
|
|
|
define Device/ubnt_edgerouter_common
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
DEVICE_VENDOR := Ubiquiti
|
|
IMAGE_SIZE := 256768k
|
|
@@ -2220,7 +2215,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg2626
|
|
|
|
define Device/zbtlink_zbt-wg3526-16m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 16064k
|
|
DEVICE_VENDOR := Zbtlink
|
|
@@ -2233,7 +2227,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
|
|
|
|
define Device/zbtlink_zbt-wg3526-32m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 32448k
|
|
DEVICE_VENDOR := Zbtlink
|