gluon/patches/openwrt/0004-ramips-mt7621-make-DSA-images-swconfig-upgradable.patch
Tom Herbers a6d75c010e
modules: update openwrt
f579b8538b ath79: add low_mem to tiny image
4b5bd15091 ath79: move ubnt-xm to tiny
977f6f36a0 kernel: fix possible mtd NULL pointer dereference
562894b39d treewide: fix security issues by bumping all packages using libwolfssl
ce59843662 wolfssl: fix TLSv1.3 RCE in uhttpd by using 5.5.1-stable (CVE-2022-39173)
3d2be75b0c wolfssl: refresh patches
0c8425bf11 wolfssl: bump to 5.5.0
2c49ad36fb kernel: bump 5.10 to 5.10.146
f04515e7bd kernel: bump 5.10 to 5.10.145
a91f391b59 kernel: bump 5.10 to 5.10.144
25747a4c04 ramips: fix switch setup for ASUS RT-AX53U
23d23038dd uboot-mvebu: backport LibreSSL patches for older version of LibreSSL
1ff2993edb uboot-mvebu: backport patch to fix compilation on non glibc system
d30ddfbac4 ramips: enable LZMA loader to fix Linksys RE6500 boot
ed905fce58 tools/meson: backport WSL2 fix
e5ab159fbf firmware: intel-microcode: update to 20220809
938ae92675 toolchain: Include ./include/fortify for external musl toolchain
8f72f5e4c0 toolchain: Select USE_SSTRIP with external musl toolchain
4ad6925a9e scripts: ext-toolchain: add support for musl
65bd632069 scripts: ext-toolchain: add support for info.mk in probe_cc
b0622d1221 scripts: ext-toolchain: actually probe libc type on config generation
d1a6c35591 scripts: ext-toolchain: add option to overwrite config
24cf766dfe scripts: ext-toolchain: fix wrong prefix in print_config generation
18a88668b8 rules_mk: don't include wrapped bin with external toolchains
29927e347a rules_mk: use gcc versions for external toolchain
cd117f0596 bcm53xx: backport clk driver fix for DT nodes names
9dc46d6549 ath79: fix LibreRouter-v1 watchdog and poe_pass
0cb3a616e4 build: fix warnings from grep
463fe05d9e Makefile: fix stray \ warnings with grep-3.8
25d8b9cad6 build: fix issues with targets installed via feeds
74eeee1698 build: fix including modules.mk for targets pulled in from feeds
dafac183f3 mpc85xx: add patch to fix gpio mpc8xxx
7707b47c72 ramips: fix fw_setsys
f3ffb04a43 kernel: add missing symbol
2a6346725a bcm4908: fix -EPROBE_DEFER support in bcm4908_enet
700f5d2990 kernel: update U-Boot NVMEM driver
acc78a9cf6 bcm4908: backport mtd parser for Broadcom's U-Boot partition
b472753d79 mediatek: fix Unifi 6LR network config
c0b7b2049e mpc85xx: fix unset kernel symbols
7c459ac1d5 mac80211: rt2x00: experimental improvements for MT7620 wifi
d004110ef7 mac80211: rt2x00: fix typo
0755c18ff1 mac80211: add patch descriptions to rt2x00 patches
7a26f40217 mediatek: fix ledbar of UniFi 6 LR when running custom U-Boot
f54d4ea0bb ramips: add support for Ubiquiti UniFi FlexHD
a28ccd58ed ath79: Make patches apply again
2419546cee generic: move ledbar driver from mediatek target
420a86436f mediatek: add led count
40610c5322 mediatek: add initialization after reset
26cd0c1ee9 mediatek: add support for reset gpio
b5665a0045 mediatek: support reading more than one byte of response
cd0283788f mediatek: cast literal value to char
a2d251573b mediatek: correctly log i2c response
7366ee86ef mediatek: remove gpiod_direction_output()
ba6c780acb mediatek: do not use gpiod_set_raw_value()
745d3cd4aa kernel: modules: package kmod-crypto-essiv
a3f9b42789 mediatek: fix typo in bpi-r64 image recipe
29c5d5d3da mediatek: bpi-r64: make initramfs/recovery optional
d10352917b ramips: fix GB-PC1 and GB-PC2 LEDs
0c9833d0e0 wireless-regdb: update to 2022-08-12
be4abbd84a kernel: bump 5.10 to 5.10.143
4e05e7dddf kernel: bump 5.10 to 5.10.142
1b0db300cb kernel: bump 5.10 to 5.10.141
bf65d2dcba kernel: bump 5.10 to 5.10.139
e7ef88ff1d kernel: build crypto md5/sha1/sha256 modules for powerpc
2022-10-06 16:21:33 +02:00

73 lines
2.1 KiB
Diff

From: David Bauer <mail@david-bauer.net>
Date: Sun, 5 Jun 2022 23:43:38 +0200
Subject: ramips-mt7621: make DSA images swconfig upgradable
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index c07ab39afdebd38b7e1764b86eaceb4e2108768c..635e1a0b006347197751d8850feed3c30202a1ea 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -172,7 +172,6 @@ endef
TARGET_DEVICES += asiarf_ap7621-nv1
define Device/asus_rt-ac57u
- $(Device/dsa-migration)
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC57U
DEVICE_ALT0_VENDOR := ASUS
@@ -418,7 +417,6 @@ endef
TARGET_DEVICES += dlink_dir-853-r1
define Device/dlink_dir-860l-b1
- $(Device/dsa-migration)
$(Device/seama)
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
LOADER_TYPE := bin
@@ -1227,7 +1225,6 @@ endef
TARGET_DEVICES += mts_wg430223
define Device/netgear_ex6150
- $(Device/dsa-migration)
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX6150
DEVICE_PACKAGES := kmod-mt76x2
@@ -1239,7 +1236,6 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -1422,7 +1418,6 @@ endef
TARGET_DEVICES += netgear_wax202
define Device/netgear_wndr3700-v5
- $(Device/dsa-migration)
$(Device/netgear_sercomm_nor)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 15232k
@@ -1746,7 +1741,6 @@ endef
TARGET_DEVICES += tplink_tl-wpa8631p-v3
define Device/ubnt_edgerouter_common
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
@@ -2143,7 +2137,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg2626
define Device/zbtlink_zbt-wg3526-16m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
@@ -2156,7 +2149,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
define Device/zbtlink_zbt-wg3526-32m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Zbtlink