35 lines
1.6 KiB
Diff
35 lines
1.6 KiB
Diff
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Mon, 9 Jul 2018 22:13:19 +0200
|
|
Subject: include/feeds.mk: always add available feeds to PACKAGE_SUBDIRS
|
|
|
|
Setting CONFIG_FEED_... symbols combined two different effects: Disabling
|
|
a feed in the generated opkg distfeeds.conf, and omitting the feed from
|
|
PACKAGE_SUBDIRS.
|
|
|
|
It does not make sense to omit built feeds from PACKAGE_SUBDIRS, as it will
|
|
only lead to packages that can be enabled in .config (and that will
|
|
consequently be built) not to be found during rootfs creation, breaking
|
|
the build. All feeds that packages are emitted to should simply always be
|
|
added to PACKAGE_SUBDIRS instead; the CONFIG_FEED_... only configure the
|
|
generated distfeeds.conf like this.
|
|
|
|
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
|
|
diff --git a/include/feeds.mk b/include/feeds.mk
|
|
index cecd30424f19525fc7bbb606b45c1e5baf9e8157..c9ffa95a368a72fd43a7e688b7ee1b274ade2916 100644
|
|
--- a/include/feeds.mk
|
|
+++ b/include/feeds.mk
|
|
@@ -16,11 +16,7 @@ FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))
|
|
PACKAGE_SUBDIRS=$(PACKAGE_DIR)
|
|
ifneq ($(CONFIG_PER_FEED_REPO),)
|
|
PACKAGE_SUBDIRS += $(OUTPUT_DIR)/packages/$(ARCH_PACKAGES)/base
|
|
- ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
|
|
- PACKAGE_SUBDIRS += $(foreach FEED,$(FEEDS_AVAILABLE),$(OUTPUT_DIR)/packages/$(ARCH_PACKAGES)/$(FEED))
|
|
- else
|
|
- PACKAGE_SUBDIRS += $(foreach FEED,$(FEEDS_ENABLED),$(OUTPUT_DIR)/packages/$(ARCH_PACKAGES)/$(FEED))
|
|
- endif
|
|
+ PACKAGE_SUBDIRS += $(foreach FEED,$(FEEDS_AVAILABLE),$(OUTPUT_DIR)/packages/$(ARCH_PACKAGES)/$(FEED))
|
|
endif
|
|
|
|
opkg_package_files = $(wildcard \
|