gluon/patches/openwrt/0004-ramips-mt7621-make-DSA-images-swconfig-upgradable.patch
David Bauer 94731839c8 modules: update openwrt
c2331038b2 kernel: remove obsolete netfilter tcp window size check bypass patch
4ae854d055 mac80211, mt76: add fixes for recently discovered security issues
b573a785e0 ncm: add error check and retry mechanism for gcom call
f61c5cf76b kernel: bump 5.10 to 5.10.176
a4212b77c0 kernel: bump 5.10 to 5.10.175
6b19d24254 kernel: bump 5.10 to 5.10.174
24d84a13a4 kernel: bump 5.10 to 5.10.173
36bf158b47 kernel: tcindex classifier has been retired
999cb9574f x86: fix deprecated CONFIG_MICROCODE_OLD_INTERACE
a88c65507d kernel: bump 5.10 to 5.10.172
cb91aa4b29 kernel: bump 5.10 to 5.10.170
26cc831e44 kernel: bump 5.10 to 5.10.169
28e5045f3a bcm4908: include usbport trigger
836e3d1e5e bcm4908: backport v6.4 pending DTS changes
b7c031d933 ipq40xx: Linksys MR8300: fix the USB port power
0170bc1af1 ramips: mt7621: enable lzma-loader for AFOUNDRY EW1200
96e3fee7ad ramips: fix 5g mac for TOTOLINK X5000R
f5db04e8ea ramips: add support for Mercusys MR70X
c58959dc45 firmware-utils: tplink-safeloader: add Mercusys MR70X
c1bfb704b1 ramips: fix Archer AX23  WiFi MAC address conflict
3c6692ba03 ramips: add support for TP-Link Archer AX23 v1
a507243bfe firmware-utils: tplink-safeloader: add TP-Link Archer AX23 v1
788a0cf15c mpc85xx: add support for Watchguard Firebox T10
2023-03-31 14:00:11 +02:00

73 lines
2.1 KiB
Diff

From: David Bauer <mail@david-bauer.net>
Date: Sun, 5 Jun 2022 23:43:38 +0200
Subject: ramips-mt7621: make DSA images swconfig upgradable
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1fb806043460895182159504f48708ae717379cb..3c26f75b9a1cbc397154b3eef4b29ec7d3d7f0db 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -180,7 +180,6 @@ endef
TARGET_DEVICES += asiarf_ap7621-nv1
define Device/asus_rt-ac57u
- $(Device/dsa-migration)
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC57U
DEVICE_ALT0_VENDOR := ASUS
@@ -427,7 +426,6 @@ endef
TARGET_DEVICES += dlink_dir-853-r1
define Device/dlink_dir-860l-b1
- $(Device/dsa-migration)
$(Device/seama-lzma-loader)
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
IMAGE_SIZE := 16064k
@@ -1247,7 +1245,6 @@ endef
TARGET_DEVICES += mts_wg430223
define Device/netgear_ex6150
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX6150
@@ -1260,7 +1257,6 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -1443,7 +1439,6 @@ endef
TARGET_DEVICES += netgear_wax202
define Device/netgear_wndr3700-v5
- $(Device/dsa-migration)
$(Device/netgear_sercomm_nor)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 15232k
@@ -1780,7 +1775,6 @@ endef
TARGET_DEVICES += tplink_tl-wpa8631p-v3
define Device/ubnt_edgerouter_common
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
@@ -2196,7 +2190,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg2626
define Device/zbtlink_zbt-wg3526-16m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
@@ -2209,7 +2202,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
define Device/zbtlink_zbt-wg3526-32m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Zbtlink