gluon/patches/openwrt/0004-ramips-mt7621-make-DSA-images-swconfig-upgradable.patch
Tom Herbers 2fd9b8aa19
modules: update openwrt
8b6b73d0e8 wolfssl: make shared again
7ca89e1187 kernel: bump 5.10 to 5.10.134
1db4f5cba3 x86: update defconfig for 5.10.133
762703d397 kernel: bump 5.10 to 5.10.133
aedcbaae37 kernel: bump 5.10 to 5.10.132
a409bd7705 octeon: add SUPPORTED_DEVICES to er/erlite
e0d3dc5de1 uboot-bcm4908: include SoC in output files
066547b974 bcm4908: build bootfs image per-SoC
506432a783 lantiq: fix network port GPIO settings for Fritzbox 3390
ee27a2b706 ipq806x: Archer VR2600: fix switch ports numbering
f2c12b8940 layerscape: update PKG_HASH / PKG_MIRROR_HASH
bddfd3f7ed sdk: add spidev-test to the bundle of userspace sources
396dc89ee7 realtek: correct egress frame port verification
f8a44c22d4 realtek: correct egress frame priority assignment
4da0b5a786 realtek: fix egress L2 learning on rtl839x
8614b8eb5f realtek: fix egress port mask on rtl839x
c240fed242 ramips: add support for Netgear WAX202
d5858c6d97 image: add support for Netgear encrypted image
a1068f77c9 wolfssl: Do not activate HW acceleration on armvirt by default
dbe19b1041 libpcap: fix PKG_CONFIG_DEPENDS for rpcapd
a12eb71c88 wolfssl: WOLFSSL_HAS_WPAS requires WOLFSSL_HAS_DH
41fa086e6f kernel: Refresh kernel patches
aa237757e0 kernel: bump 5.10 to 5.10.131
a51f54b41d kernel: bump 5.10 to 5.10.130
f14122f8e6 kernel: bump 5.10 to 5.10.129
73ef008ea6 kernel: bump 5.10 to 5.10.128
cb9a69807e firewall3: bump to latest git HEAD
8ccd657629 mt7622: remove 300 MHz from dts
606fc4cd81 bcm4908: use upstream-accepted watchdog patches
7eda42a3f3 bcm4908: backport latest DT patches
187f5147d3 kernel: update leds-bcm63138 driver
f1fc90e5a1 kernel: backport LEDs driver for BCMBCA devices
a8001815a6 opkg: update to 2022-02-24
479890083d firmware: intel-microcode: update to 20220510
c5ee4b7863 openssl: bump to 1.1.1q
ade7c6db1e wolfssl: bump to 5.4.0
409534860f ath79: bsap18x0: pad rootfs image
1be4cad669 ath79: ja76pf2: use nvmem cells to specify MAC addresses
94530067ad ath79: move image check for devices with RedBoot
8e09f9ffc3 ath79: switch some RedBoot based devices to OKLI loader
01b8cd3200 rockchip: reliably distribute net interrupts
4fb05e45df wolfssl: re-enable AES-NI by default for x86_64
ec9f82fa18 mac80211: fix AQL issue with multicast traffic
945b13e369 realtek: build sane factory images for DGS-1210 models
3fbf45bd09 realtek: build factory images for all DGS-1210 models
128575d0fd realtek: rename u-boot-env2 to board-name
9081098273 scripts: fix CAMEO tag generator
87e58a43ea realtek: build DGS-1210 images with CAMEO tag
b151362d19 scripts: add CAMEO tag generator
72466aaeb9 realtek: add DGS-1210-28 factory image
b2876e6a3a scripts: add cameo image header generator
8b4169f1c9 bcm53xx: use -falign-functions=32 for kernel compilation
e291e49da3 bcm53xx: enable & setup packet steering
5359a8ca38 bcm53xx: disable GRO by default at kernel level
027f7b18b9 bcm53xx: revert bgmac back to the old limited max frame size
bd826dc9f9 kernel: drop patch adding hardcoded kernel compilation flags
da7c57b086 kernel: support setting extra CFLAGS for kernel compilation
614a420084 kernel: use KCFLAGS for passing EXTRA_OPTIMIZATION flags
2022-07-31 13:49:45 +02:00

73 lines
2.1 KiB
Diff

From: David Bauer <mail@david-bauer.net>
Date: Sun, 5 Jun 2022 23:43:38 +0200
Subject: ramips-mt7621: make DSA images swconfig upgradable
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 30442175bf6a3f888a8e8b8fc0186bb41717f8e3..1261770813ddb80a17b47333b7244dc3b9e0f14d 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -171,7 +171,6 @@ endef
TARGET_DEVICES += asiarf_ap7621-nv1
define Device/asus_rt-ac57u
- $(Device/dsa-migration)
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC57U
DEVICE_ALT0_VENDOR := ASUS
@@ -400,7 +399,6 @@ endef
TARGET_DEVICES += dlink_dir-853-r1
define Device/dlink_dir-860l-b1
- $(Device/dsa-migration)
$(Device/seama)
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
LOADER_TYPE := bin
@@ -1185,7 +1183,6 @@ endef
TARGET_DEVICES += mtc_wr1201
define Device/netgear_ex6150
- $(Device/dsa-migration)
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX6150
DEVICE_PACKAGES := kmod-mt76x2
@@ -1197,7 +1194,6 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -1380,7 +1376,6 @@ endef
TARGET_DEVICES += netgear_wax202
define Device/netgear_wndr3700-v5
- $(Device/dsa-migration)
$(Device/netgear_sercomm_nor)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 15232k
@@ -1704,7 +1699,6 @@ endef
TARGET_DEVICES += tplink_tl-wpa8631p-v3
define Device/ubnt_edgerouter_common
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
@@ -2090,7 +2084,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg2626
define Device/zbtlink_zbt-wg3526-16m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
@@ -2103,7 +2096,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
define Device/zbtlink_zbt-wg3526-32m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Zbtlink