b6c576645f
fix rescue mode on wdr4900 Backport of r48793
22 lines
712 B
Diff
22 lines
712 B
Diff
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Sun, 28 Feb 2016 03:42:29 +0100
|
|
Subject: kernel/gpio_keys: load module on pre-init
|
|
|
|
fix rescue mode on wdr4900
|
|
|
|
Backport of r48793
|
|
|
|
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
|
|
index 86ff33c..eed9aa2 100644
|
|
--- a/package/kernel/linux/modules/input.mk
|
|
+++ b/package/kernel/linux/modules/input.mk
|
|
@@ -75,7 +75,7 @@ define KernelPackage/input-gpio-keys
|
|
CONFIG_KEYBOARD_GPIO \
|
|
CONFIG_INPUT_KEYBOARD=y
|
|
FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
|
|
- AUTOLOAD:=$(call AutoProbe,gpio_keys)
|
|
+ AUTOLOAD:=$(call AutoProbe,gpio_keys,1)
|
|
endef
|
|
|
|
define KernelPackage/input-gpio-keys/description
|