gluon/patches/openwrt/0004-ramips-mt7621-make-DSA-images-swconfig-upgradable.patch
Tom Herbers 29b26c467d
modules: update openwrt
f579b8538b ath79: add low_mem to tiny image
4b5bd15091 ath79: move ubnt-xm to tiny
977f6f36a0 kernel: fix possible mtd NULL pointer dereference
562894b39d treewide: fix security issues by bumping all packages using libwolfssl
ce59843662 wolfssl: fix TLSv1.3 RCE in uhttpd by using 5.5.1-stable (CVE-2022-39173)
3d2be75b0c wolfssl: refresh patches
0c8425bf11 wolfssl: bump to 5.5.0
2c49ad36fb kernel: bump 5.10 to 5.10.146
f04515e7bd kernel: bump 5.10 to 5.10.145
a91f391b59 kernel: bump 5.10 to 5.10.144
25747a4c04 ramips: fix switch setup for ASUS RT-AX53U
23d23038dd uboot-mvebu: backport LibreSSL patches for older version of LibreSSL
1ff2993edb uboot-mvebu: backport patch to fix compilation on non glibc system
d30ddfbac4 ramips: enable LZMA loader to fix Linksys RE6500 boot
ed905fce58 tools/meson: backport WSL2 fix
e5ab159fbf firmware: intel-microcode: update to 20220809
938ae92675 toolchain: Include ./include/fortify for external musl toolchain
8f72f5e4c0 toolchain: Select USE_SSTRIP with external musl toolchain
4ad6925a9e scripts: ext-toolchain: add support for musl
65bd632069 scripts: ext-toolchain: add support for info.mk in probe_cc
b0622d1221 scripts: ext-toolchain: actually probe libc type on config generation
d1a6c35591 scripts: ext-toolchain: add option to overwrite config
24cf766dfe scripts: ext-toolchain: fix wrong prefix in print_config generation
18a88668b8 rules_mk: don't include wrapped bin with external toolchains
29927e347a rules_mk: use gcc versions for external toolchain
cd117f0596 bcm53xx: backport clk driver fix for DT nodes names
9dc46d6549 ath79: fix LibreRouter-v1 watchdog and poe_pass
0cb3a616e4 build: fix warnings from grep
463fe05d9e Makefile: fix stray \ warnings with grep-3.8
25d8b9cad6 build: fix issues with targets installed via feeds
74eeee1698 build: fix including modules.mk for targets pulled in from feeds
dafac183f3 mpc85xx: add patch to fix gpio mpc8xxx
7707b47c72 ramips: fix fw_setsys
f3ffb04a43 kernel: add missing symbol
2a6346725a bcm4908: fix -EPROBE_DEFER support in bcm4908_enet
700f5d2990 kernel: update U-Boot NVMEM driver
acc78a9cf6 bcm4908: backport mtd parser for Broadcom's U-Boot partition
2022-10-06 16:11:21 +02:00

73 lines
2.1 KiB
Diff

From: David Bauer <mail@david-bauer.net>
Date: Sun, 5 Jun 2022 23:43:38 +0200
Subject: ramips-mt7621: make DSA images swconfig upgradable
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index c07ab39afdebd38b7e1764b86eaceb4e2108768c..635e1a0b006347197751d8850feed3c30202a1ea 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -172,7 +172,6 @@ endef
TARGET_DEVICES += asiarf_ap7621-nv1
define Device/asus_rt-ac57u
- $(Device/dsa-migration)
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC57U
DEVICE_ALT0_VENDOR := ASUS
@@ -418,7 +417,6 @@ endef
TARGET_DEVICES += dlink_dir-853-r1
define Device/dlink_dir-860l-b1
- $(Device/dsa-migration)
$(Device/seama)
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
LOADER_TYPE := bin
@@ -1227,7 +1225,6 @@ endef
TARGET_DEVICES += mts_wg430223
define Device/netgear_ex6150
- $(Device/dsa-migration)
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX6150
DEVICE_PACKAGES := kmod-mt76x2
@@ -1239,7 +1236,6 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -1422,7 +1418,6 @@ endef
TARGET_DEVICES += netgear_wax202
define Device/netgear_wndr3700-v5
- $(Device/dsa-migration)
$(Device/netgear_sercomm_nor)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 15232k
@@ -1746,7 +1741,6 @@ endef
TARGET_DEVICES += tplink_tl-wpa8631p-v3
define Device/ubnt_edgerouter_common
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
@@ -2143,7 +2137,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg2626
define Device/zbtlink_zbt-wg3526-16m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
@@ -2156,7 +2149,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
define Device/zbtlink_zbt-wg3526-32m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Zbtlink