gluon/patches/openwrt/0009-ath79-enable-GL-AR750S-NOR-variant-from-master.patch
2020-04-09 20:29:24 +02:00

73 lines
2.8 KiB
Diff

From 0d5a95cac5aada71108e2178e0ec5b2a6efdc415 Mon Sep 17 00:00:00 2001
From: Jan Alexander <jan@nalx.net>
Date: Tue, 31 Mar 2020 21:50:28 +0200
Subject: [PATCH] ath79: enable GL-AR750S NOR variant from master
---
target/linux/ath79/base-files/etc/board.d/02_network | 2 +-
.../ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata | 2 +-
target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts | 4 ++--
target/linux/ath79/image/generic.mk | 4 ++--
4 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 8edd4e6c2e..2d2d4e33af 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -140,7 +140,7 @@ ath79_setup_interfaces()
etactica,eg200)
ucidef_set_interface_lan "eth0" "dhcp"
;;
- glinet,gl-ar750s)
+ glinet,gl-ar750s-nor)
ucidef_add_switch "switch0" \
"0@eth0" "2:lan:2" "3:lan:1" "1:wan"
;;
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index d93e6dcd71..c917f38211 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -117,7 +117,7 @@ case "$FIRMWARE" in
ath10kcal_extract "art" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
;;
- glinet,gl-ar750s)
+ glinet,gl-ar750s-nor)
ath10kcal_extract "art" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(mtd_get_mac_binary art 0) +1)
;;
diff --git a/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
index 0145a24fba..ebecb8cc77 100644
--- a/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
+++ b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
@@ -7,8 +7,8 @@
#include "qca956x.dtsi"
/ {
- compatible = "glinet,gl-ar750s", "qca,qca9563";
- model = "GL.iNet GL-AR750S";
+ compatible = "glinet,gl-ar750s-nor", "qca,qca9563";
+ model = "GL.iNet GL-AR750S (NOR)";
chosen {
bootargs = "console=ttyS0,115200n8";
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 55053be34f..892ef10f87 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -403,9 +403,9 @@ define Device/glinet_gl-ar750s
DEVICE_TITLE := GL.iNet GL-AR750S
DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct block-mount
IMAGE_SIZE := 16000k
- SUPPORTED_DEVICES += gl-ar750s
+ SUPPORTED_DEVICES += gl-ar750s glinet,gl-ar750s-nor
endef
-#TARGET_DEVICES += glinet_gl-ar750s
+TARGET_DEVICES += glinet_gl-ar750s
define Device/glinet_gl-x750
ATH_SOC := qca9531
--
2.25.1