gluon/patches/openwrt/0004-ramips-mt7621-make-DSA-images-swconfig-upgradable.patch
David Bauer f69be80ac3 modules: update openwrt
a7fb589e8a image: always rebuild kernel loaders
5db6914f7c mpc85xx: p1010: make TP-Link WDR4900 v1 build again
f7a43e4606 mpc85xx: add SPI kernel loader for TP-Link TL-WDR4900 v1
c1fcca50ba ramips: fix ZyXEL NWA55AXE model name
2050bc4f64 ramips: add support for ZyXEL NWA50AX / NWA55AXE
bc8e24c654 busybox: nslookup: ensure unique transaction IDs for the DNS queries

(cherry picked from commit c5e297e9c8)
2022-10-17 12:26:12 +00:00

73 lines
2.1 KiB
Diff

From: David Bauer <mail@david-bauer.net>
Date: Sun, 5 Jun 2022 23:43:38 +0200
Subject: ramips-mt7621: make DSA images swconfig upgradable
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a3bdacb32a1657c15cba29512466b34a97af2e9a..b5ca3438de9fe20112110e653b016f13cb7f55ea 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -179,7 +179,6 @@ endef
TARGET_DEVICES += asiarf_ap7621-nv1
define Device/asus_rt-ac57u
- $(Device/dsa-migration)
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC57U
DEVICE_ALT0_VENDOR := ASUS
@@ -425,7 +424,6 @@ endef
TARGET_DEVICES += dlink_dir-853-r1
define Device/dlink_dir-860l-b1
- $(Device/dsa-migration)
$(Device/seama)
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
LOADER_TYPE := bin
@@ -1234,7 +1232,6 @@ endef
TARGET_DEVICES += mts_wg430223
define Device/netgear_ex6150
- $(Device/dsa-migration)
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX6150
DEVICE_PACKAGES := kmod-mt76x2
@@ -1246,7 +1243,6 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -1429,7 +1425,6 @@ endef
TARGET_DEVICES += netgear_wax202
define Device/netgear_wndr3700-v5
- $(Device/dsa-migration)
$(Device/netgear_sercomm_nor)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 15232k
@@ -1753,7 +1748,6 @@ endef
TARGET_DEVICES += tplink_tl-wpa8631p-v3
define Device/ubnt_edgerouter_common
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
@@ -2150,7 +2144,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg2626
define Device/zbtlink_zbt-wg3526-16m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
@@ -2163,7 +2156,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
define Device/zbtlink_zbt-wg3526-32m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Zbtlink