62 lines
2.7 KiB
Diff
62 lines
2.7 KiB
Diff
From: Jan Alexander <jan@nalx.net>
|
|
Date: Tue, 31 Mar 2020 21:50:28 +0200
|
|
Subject: ath79: enable GL-AR750S NOR variant from master
|
|
|
|
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
|
|
index 1b0e76b1593bfd38cfaea6dc4844ed9f222f0b6b..31b59c46699e45e2611efee046efe3ebf9521f56 100755
|
|
--- a/target/linux/ath79/base-files/etc/board.d/02_network
|
|
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
|
|
@@ -140,7 +140,7 @@ ath79_setup_interfaces()
|
|
etactica,eg200)
|
|
ucidef_set_interface_lan "eth0" "dhcp"
|
|
;;
|
|
- glinet,gl-ar750s)
|
|
+ glinet,gl-ar750s-nor)
|
|
ucidef_add_switch "switch0" \
|
|
"0@eth0" "2:lan:2" "3:lan:1" "1:wan"
|
|
;;
|
|
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
index d93e6dcd71ab19c53905daa41e95cc4fc614f114..c917f38211d0b246f064dba4b7feefecf61f5856 100644
|
|
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
@@ -117,7 +117,7 @@ case "$FIRMWARE" in
|
|
ath10kcal_extract "art" 20480 2116
|
|
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
|
|
;;
|
|
- glinet,gl-ar750s)
|
|
+ glinet,gl-ar750s-nor)
|
|
ath10kcal_extract "art" 20480 2116
|
|
ath10kcal_patch_mac $(macaddr_add $(mtd_get_mac_binary art 0) +1)
|
|
;;
|
|
diff --git a/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
|
|
index 0145a24fbae2cdbe6fb6445607795af6b792352d..ebecb8cc776091ec019638589cb88159345d367f 100644
|
|
--- a/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
|
|
+++ b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
|
|
@@ -7,8 +7,8 @@
|
|
#include "qca956x.dtsi"
|
|
|
|
/ {
|
|
- compatible = "glinet,gl-ar750s", "qca,qca9563";
|
|
- model = "GL.iNet GL-AR750S";
|
|
+ compatible = "glinet,gl-ar750s-nor", "qca,qca9563";
|
|
+ model = "GL.iNet GL-AR750S (NOR)";
|
|
|
|
chosen {
|
|
bootargs = "console=ttyS0,115200n8";
|
|
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
|
|
index 55053be34f11f0df982c85f94c9180fdba9ff221..892ef10f870e347c8a1509cecd35bce4b5e98bee 100644
|
|
--- a/target/linux/ath79/image/generic.mk
|
|
+++ b/target/linux/ath79/image/generic.mk
|
|
@@ -403,9 +403,9 @@ define Device/glinet_gl-ar750s
|
|
DEVICE_TITLE := GL.iNet GL-AR750S
|
|
DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct block-mount
|
|
IMAGE_SIZE := 16000k
|
|
- SUPPORTED_DEVICES += gl-ar750s
|
|
+ SUPPORTED_DEVICES += gl-ar750s glinet,gl-ar750s-nor
|
|
endef
|
|
-#TARGET_DEVICES += glinet_gl-ar750s
|
|
+TARGET_DEVICES += glinet_gl-ar750s
|
|
|
|
define Device/glinet_gl-x750
|
|
ATH_SOC := qca9531
|