gluon/patches/openwrt/0004-ramips-mt7621-make-DSA-images-swconfig-upgradable.patch
FFAC 2f463c0353 modules: update openwrt
5f583d31c7 ramips: mt7621: add support for Cudy X6 v2
2023-05-03 22:20:07 +00:00

65 lines
1.8 KiB
Diff

From: David Bauer <mail@david-bauer.net>
Date: Sun, 5 Jun 2022 23:43:38 +0200
Subject: ramips-mt7621: make DSA images swconfig upgradable
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index ab0ff95f7529aa43e69e67a4e3a303242c9b2605..4c3a38db442f06d6c1acf77fb729d93a67e2d52a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -180,7 +180,6 @@ endef
TARGET_DEVICES += asiarf_ap7621-nv1
define Device/asus_rt-ac57u
- $(Device/dsa-migration)
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC57U
DEVICE_ALT0_VENDOR := ASUS
@@ -1286,7 +1285,6 @@ endef
TARGET_DEVICES += mts_wg430223
define Device/netgear_ex6150
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX6150
@@ -1299,7 +1297,6 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -1482,7 +1479,6 @@ endef
TARGET_DEVICES += netgear_wax202
define Device/netgear_wndr3700-v5
- $(Device/dsa-migration)
$(Device/netgear_sercomm_nor)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 15232k
@@ -1819,7 +1815,6 @@ endef
TARGET_DEVICES += tplink_tl-wpa8631p-v3
define Device/ubnt_edgerouter_common
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
@@ -2235,7 +2230,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg2626
define Device/zbtlink_zbt-wg3526-16m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
@@ -2248,7 +2242,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
define Device/zbtlink_zbt-wg3526-32m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Zbtlink