59d4b3056f
For some reason, the filenames of the OpenMesh support patches were truncated.
58 lines
2.3 KiB
Diff
58 lines
2.3 KiB
Diff
From: Sven Eckelmann <sven.eckelmann@open-mesh.com>
|
|
Date: Mon, 14 Sep 2015 20:11:51 +0000
|
|
Subject: ar71xx: create profile and build image for the OpenMesh MR1750 board
|
|
|
|
Signed-off-by: Sven Eckelmann <sven.eckelmann@open-mesh.com>
|
|
|
|
Backport of r46932
|
|
|
|
Forwarded: https://patchwork.ozlabs.org/patch/624179/
|
|
|
|
diff --git a/target/linux/ar71xx/generic/profiles/openmesh.mk b/target/linux/ar71xx/generic/profiles/openmesh.mk
|
|
index 41b462e..06cf135 100644
|
|
--- a/target/linux/ar71xx/generic/profiles/openmesh.mk
|
|
+++ b/target/linux/ar71xx/generic/profiles/openmesh.mk
|
|
@@ -49,9 +49,20 @@ endef
|
|
|
|
$(eval $(call Profile,MR900))
|
|
|
|
+define Profile/MR1750
|
|
+ NAME:=OpenMesh MR1750
|
|
+ PACKAGES:=kmod-ath9k kmod-ath10k ath10k-firmware-qca988x
|
|
+endef
|
|
+
|
|
+define Profile/MR1750/Description
|
|
+ Package set optimized for the OpenMesh MR1750.
|
|
+endef
|
|
+
|
|
+$(eval $(call Profile,MR1750))
|
|
+
|
|
define Profile/OPENMESH
|
|
NAME:=OpenMesh products
|
|
- PACKAGES:=kmod-ath9k om-watchdog
|
|
+ PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
|
|
endef
|
|
|
|
define Profile/OPENMESH/Description
|
|
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
|
|
index f91e20e..b74aa45 100644
|
|
--- a/target/linux/ar71xx/image/Makefile
|
|
+++ b/target/linux/ar71xx/image/Makefile
|
|
@@ -2045,6 +2045,7 @@ $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM2P,om2p,,,,OM2P))
|
|
$(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5P,om5p,,,,OM5P))
|
|
$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR600,mr600,,,,MR600))
|
|
$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR900,mr900,,,,MR900))
|
|
+$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR1750,mr1750,,,,MR1750))
|
|
|
|
$(eval $(call SingleProfile,PB4X,128k,ALL0305,all0305,ALL0305,ttyS0,115200))
|
|
$(eval $(call SingleProfile,PB4X,128k,EAP7660D,eap7660d,EAP7660D,ttyS0,115200))
|
|
@@ -2138,7 +2139,7 @@ $(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
|
|
$(eval $(call MultiProfile,DIR615IX,DIR615I1 DIR615I3))
|
|
$(eval $(call MultiProfile,AP136,AP136_010 AP136_020))
|
|
$(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
|
|
-$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900))
|
|
+$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900 MR1750))
|
|
$(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
|
|
$(eval $(call MultiProfile,TLMR3220,TLMR3220V1))
|
|
$(eval $(call MultiProfile,TLMR3420,TLMR3420V1))
|