087112a09b
Also backport some patches improving QCA956x support.
275 lines
8.6 KiB
Diff
275 lines
8.6 KiB
Diff
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Fri, 13 May 2016 21:34:05 +0200
|
|
Subject: ar71xx: Add support for Ubiquiti UniFi AP AC PRO
|
|
|
|
Add support for the Ubiquiti UniFi AP AC PRO
|
|
Signed-off-by: P.Wassi <p.wassi at gmx.at>
|
|
|
|
Backport of LEDE 8307c2fe686ded345c80318359d5b6679e581fa2
|
|
|
|
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
|
|
index 3d711ca..775aac6 100644
|
|
--- a/target/linux/ar71xx/base-files/etc/diag.sh
|
|
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
|
|
@@ -297,7 +297,8 @@ get_status_led() {
|
|
status_led="ubnt:green:dome"
|
|
;;
|
|
uap-pro | \
|
|
- unifiac-lite)
|
|
+ unifiac-lite | \
|
|
+ unifiac-pro)
|
|
status_led="ubnt:white:dome"
|
|
;;
|
|
unifi-outdoor-plus)
|
|
diff --git a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
index fa8a2c8..cde7aaf 100644
|
|
--- a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
+++ b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
@@ -75,7 +75,8 @@ case "$FIRMWARE" in
|
|
ath10kcal_extract "ART" 20480 2116
|
|
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
|
|
;;
|
|
- unifiac-lite)
|
|
+ unifiac-lite | \
|
|
+ unifiac-pro)
|
|
ath10kcal_extract "EEPROM" 20480 2116
|
|
;;
|
|
esac
|
|
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
|
|
index 0269e6d..0a23756 100755
|
|
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
|
|
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
|
|
@@ -398,6 +398,13 @@ wpj344)
|
|
ucidef_add_switch_vlan "switch0" "2" "0t 2"
|
|
;;
|
|
|
|
+unifiac-pro)
|
|
+ ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
|
|
+ ucidef_add_switch "switch0" "1" "1"
|
|
+ ucidef_add_switch_vlan "switch0" "1" "0t 2"
|
|
+ ucidef_add_switch_vlan "switch0" "2" "0t 3"
|
|
+ ;;
|
|
+
|
|
wpj531)
|
|
ucidef_set_interfaces_lan_wan "eth0" "eth1"
|
|
;;
|
|
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
|
|
index d3e6db9..7fc951a 100755
|
|
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
|
|
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
|
|
@@ -884,6 +884,9 @@ ar71xx_board_detect() {
|
|
*"UniFi-AC-LITE")
|
|
name="unifiac-lite"
|
|
;;
|
|
+ *"UniFi-AC-PRO")
|
|
+ name="unifiac-pro"
|
|
+ ;;
|
|
*"UniFi AP Pro")
|
|
name="uap-pro"
|
|
;;
|
|
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
|
|
index a1b65b7..0e9833d 100755
|
|
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
|
|
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
|
|
@@ -252,6 +252,7 @@ platform_check_image() {
|
|
nbg460n_550n_550nh | \
|
|
unifi | \
|
|
unifiac-lite | \
|
|
+ unifiac-pro | \
|
|
unifi-outdoor | \
|
|
carambola2 | \
|
|
weio )
|
|
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-ubnt-unifiac.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-ubnt-unifiac.c
|
|
index 31cbe30..9194bc1 100644
|
|
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-ubnt-unifiac.c
|
|
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-ubnt-unifiac.c
|
|
@@ -21,6 +21,7 @@
|
|
#include <asm/mach-ath79/ar71xx_regs.h>
|
|
|
|
#include <linux/platform_data/phy-at803x.h>
|
|
+#include <linux/ar8216_platform.h>
|
|
|
|
#include "common.h"
|
|
#include "dev-ap9x-pci.h"
|
|
@@ -29,6 +30,7 @@
|
|
#include "dev-leds-gpio.h"
|
|
#include "dev-m25p80.h"
|
|
#include "dev-wmac.h"
|
|
+#include "dev-usb.h"
|
|
#include "machtypes.h"
|
|
|
|
|
|
@@ -108,3 +110,70 @@ static void __init ubnt_unifiac_lite_setup(void)
|
|
|
|
MIPS_MACHINE(ATH79_MACH_UBNT_UNIFIAC_LITE, "UBNT-UF-AC-LITE", "Ubiquiti UniFi-AC-LITE",
|
|
ubnt_unifiac_lite_setup);
|
|
+
|
|
+static struct ar8327_pad_cfg ubnt_unifiac_pro_ar8327_pad0_cfg = {
|
|
+ .mode = AR8327_PAD_MAC_SGMII,
|
|
+ .sgmii_delay_en = true,
|
|
+};
|
|
+
|
|
+static struct ar8327_platform_data ubnt_unifiac_pro_ar8327_data = {
|
|
+ .pad0_cfg = &ubnt_unifiac_pro_ar8327_pad0_cfg,
|
|
+ .port0_cfg = {
|
|
+ .force_link = 1,
|
|
+ .speed = AR8327_PORT_SPEED_1000,
|
|
+ .duplex = 1,
|
|
+ .txpause = 1,
|
|
+ .rxpause = 1,
|
|
+ },
|
|
+};
|
|
+
|
|
+
|
|
+static struct mdio_board_info ubnt_unifiac_pro_mdio0_info[] = {
|
|
+ {
|
|
+ .bus_id = "ag71xx-mdio.0",
|
|
+ .phy_addr = 0,
|
|
+ .platform_data = &ubnt_unifiac_pro_ar8327_data,
|
|
+ },
|
|
+};
|
|
+
|
|
+static void __init ubnt_unifiac_pro_setup(void)
|
|
+{
|
|
+ u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff0000);
|
|
+
|
|
+ ath79_register_m25p80(&ubnt_unifiac_flash_data);
|
|
+
|
|
+
|
|
+ ath79_init_mac(ath79_eth0_data.mac_addr,
|
|
+ eeprom + UNIFIAC_MAC0_OFFSET, 0);
|
|
+
|
|
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
|
|
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
|
|
+ ath79_eth0_data.phy_mask = BIT(0);
|
|
+
|
|
+ mdiobus_register_board_info(ubnt_unifiac_pro_mdio0_info,
|
|
+ ARRAY_SIZE(ubnt_unifiac_pro_mdio0_info));
|
|
+
|
|
+ ath79_register_mdio(0, 0x00);
|
|
+ ath79_register_eth(0);
|
|
+
|
|
+
|
|
+ ath79_register_usb();
|
|
+
|
|
+
|
|
+ ath79_register_wmac(eeprom + UNIFIAC_WMAC_CALDATA_OFFSET, NULL);
|
|
+
|
|
+
|
|
+ ap91_pci_init(eeprom + UNIFIAC_PCI_CALDATA_OFFSET, NULL);
|
|
+
|
|
+
|
|
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(ubnt_unifiac_leds_gpio),
|
|
+ ubnt_unifiac_leds_gpio);
|
|
+
|
|
+ ath79_register_gpio_keys_polled(-1, UNIFIAC_KEYS_POLL_INTERVAL,
|
|
+ ARRAY_SIZE(ubnt_unifiac_gpio_keys),
|
|
+ ubnt_unifiac_gpio_keys);
|
|
+}
|
|
+
|
|
+
|
|
+MIPS_MACHINE(ATH79_MACH_UBNT_UNIFIAC_PRO, "UBNT-UF-AC-PRO", "Ubiquiti UniFi-AC-PRO",
|
|
+ ubnt_unifiac_pro_setup);
|
|
diff --git a/target/linux/ar71xx/generic/profiles/ubnt.mk b/target/linux/ar71xx/generic/profiles/ubnt.mk
|
|
index eac0240..69b8398 100644
|
|
--- a/target/linux/ar71xx/generic/profiles/ubnt.mk
|
|
+++ b/target/linux/ar71xx/generic/profiles/ubnt.mk
|
|
@@ -49,6 +49,17 @@ endef
|
|
|
|
$(eval $(call Profile,UBNTUNIFIACLITE))
|
|
|
|
+define Profile/UBNTUNIFIACPRO
|
|
+ NAME:=Ubiquiti UniFi AP AC PRO
|
|
+ PACKAGES:=kmod-ath10k ath10k-firmware-qca988x kmod-usb-core kmod-usb-ohci kmod-usb2
|
|
+endef
|
|
+
|
|
+define Profile/UBNTUNIFIACPRO/Description
|
|
+ Package set optimized for the Ubiquiti UniFi AP AC PRO.
|
|
+endef
|
|
+
|
|
+$(eval $(call Profile,UBNTUNIFIACPRO))
|
|
+
|
|
define Profile/UBNTUNIFIOUTDOOR
|
|
NAME:=Ubiquiti UniFiAP Outdoor
|
|
PACKAGES:=
|
|
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
|
|
index 31aff78..916d4e2 100644
|
|
--- a/target/linux/ar71xx/image/Makefile
|
|
+++ b/target/linux/ar71xx/image/Makefile
|
|
@@ -753,7 +753,13 @@ define Device/ubnt-unifiac-lite
|
|
DEVICE_PROFILE := UBNT UBNTUNIFIACLITE
|
|
BOARDNAME := UBNT-UF-AC
|
|
endef
|
|
-TARGET_DEVICES += ubnt-unifiac-lite
|
|
+
|
|
+define Device/ubnt-unifiac-pro
|
|
+ $(Device/ubnt-unifiac)
|
|
+ DEVICE_PROFILE := UBNT UBNTUNIFIACPRO
|
|
+ BOARDNAME := UBNT-UF-AC-PRO
|
|
+endef
|
|
+TARGET_DEVICES += ubnt-unifiac-lite ubnt-unifiac-pro
|
|
|
|
rootfs_type=$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))
|
|
|
|
diff --git a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
|
|
index 0ade403..dbd3fca 100644
|
|
--- a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
|
|
+++ b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
|
|
@@ -1,6 +1,6 @@
|
|
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
-@@ -16,22 +16,200 @@
|
|
+@@ -16,22 +16,201 @@
|
|
|
|
enum ath79_mach_type {
|
|
ATH79_MACH_GENERIC = 0,
|
|
@@ -165,6 +165,7 @@
|
|
ATH79_MACH_UBNT_UAP_PRO, /* Ubiquiti UniFi AP Pro */
|
|
ATH79_MACH_UBNT_UNIFI, /* Ubiquiti Unifi */
|
|
+ ATH79_MACH_UBNT_UNIFIAC_LITE, /* Ubiquiti Unifi AC LITE/LR */
|
|
++ ATH79_MACH_UBNT_UNIFIAC_PRO, /* Ubiquiti Unifi AC PRO */
|
|
ATH79_MACH_UBNT_UNIFI_OUTDOOR, /* Ubiquiti UnifiAP Outdoor */
|
|
+ ATH79_MACH_UBNT_UNIFI_OUTDOOR_PLUS, /* Ubiquiti UnifiAP Outdoor+ */
|
|
ATH79_MACH_UBNT_XM, /* Ubiquiti Networks XM board rev 1.0 */
|
|
@@ -1363,12 +1364,12 @@
|
|
|
|
config ATH79_MACH_UBNT_XM
|
|
bool "Ubiquiti Networks XM/UniFi boards"
|
|
-@@ -83,6 +1144,116 @@ config ATH79_MACH_UBNT_XM
|
|
+@@ -83,6 +1144,117 @@ config ATH79_MACH_UBNT_XM
|
|
Say 'Y' here if you want your kernel to support the
|
|
Ubiquiti Networks XM (rev 1.0) board.
|
|
|
|
+config ATH79_MACH_UBNT_UNIFIAC
|
|
-+ bool "Ubiquiti UniFi AC (LITE/LR) support"
|
|
++ bool "Ubiquiti UniFi AC (LITE/LR/PRO) support"
|
|
+ select SOC_QCA956X
|
|
+ select ATH79_DEV_AP9X_PCI if PCI
|
|
+ select ATH79_DEV_ETH
|
|
@@ -1376,6 +1377,7 @@
|
|
+ select ATH79_DEV_LEDS_GPIO
|
|
+ select ATH79_DEV_M25P80
|
|
+ select ATH79_DEV_WMAC
|
|
++ select ATH79_DEV_USB
|
|
+
|
|
+config ATH79_MACH_WEIO
|
|
+ bool "WeIO board"
|
|
@@ -1480,7 +1482,7 @@
|
|
endmenu
|
|
|
|
config SOC_AR71XX
|
|
-@@ -124,7 +1295,10 @@ config ATH79_DEV_DSA
|
|
+@@ -124,7 +1296,10 @@ config ATH79_DEV_DSA
|
|
config ATH79_DEV_ETH
|
|
def_bool n
|
|
|
|
@@ -1492,7 +1494,7 @@
|
|
def_bool n
|
|
|
|
config ATH79_DEV_GPIO_BUTTONS
|
|
-@@ -154,6 +1328,11 @@ config ATH79_PCI_ATH9K_FIXUP
|
|
+@@ -154,6 +1329,11 @@ config ATH79_PCI_ATH9K_FIXUP
|
|
def_bool n
|
|
|
|
config ATH79_ROUTERBOOT
|