32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Sun, 24 Apr 2016 08:44:47 +0200
|
|
Subject: tools: compile flock before everything else
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|
|
|
Backport of r48413
|
|
|
|
diff --git a/tools/Makefile b/tools/Makefile
|
|
index 98ce8c5..3402c08 100644
|
|
--- a/tools/Makefile
|
|
+++ b/tools/Makefile
|
|
@@ -26,7 +26,7 @@ endif
|
|
tools-$(BUILD_TOOLCHAIN) += gmp mpfr mpc libelf
|
|
tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
|
|
tools-y += sstrip make-ext4fs e2fsprogs mtd-utils mkimage
|
|
-tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
|
|
+tools-y += firmware-utils patch-image patch quilt yaffs2 padjffs2
|
|
tools-y += mm-macros missing-macros xz cmake scons bc findutils gengetopt patchelf
|
|
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
|
|
tools-$(CONFIG_powerpc) += upx
|
|
@@ -84,6 +84,9 @@ $(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(
|
|
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/tar/install))
|
|
tools-y += tar
|
|
|
|
+$(curdir)/tar/compile := $(curdir)/flock/install
|
|
+tools-y += flock
|
|
+
|
|
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
|
|
$(curdir)/builddirs-default := $(tools-y)
|
|
|