e773f686c9
Caused by a broken backport. Fixes #689
31 lines
1.2 KiB
Diff
31 lines
1.2 KiB
Diff
From: Sven Eckelmann <sven.eckelmann@open-mesh.com>
|
|
Date: Tue, 17 May 2016 16:38:29 +0200
|
|
Subject: ar71xx: Generate sysupgrade images for OpenMesh devices
|
|
|
|
Some OpenWrt based firmwares like Gluon expect that a sysupgrade image
|
|
exists when a device firmware can be updated via sysupgrade. This image
|
|
wasn't created until now because OpenMesh devices use the same image for
|
|
factory and sysupgrade flash. Copying the image from *factory.bin to
|
|
*sysupgrade.bin is therefore enough to make the sysupgrade functionality
|
|
visible.
|
|
|
|
Reported-by: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Signed-off-by: Sven Eckelmann <sven.eckelmann@open-mesh.com>
|
|
|
|
Forwarded: https://patchwork.ozlabs.org/patch/624172/
|
|
|
|
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
|
|
index 58118f2..7aee0c8 100644
|
|
--- a/target/linux/ar71xx/image/Makefile
|
|
+++ b/target/linux/ar71xx/image/Makefile
|
|
@@ -1877,6 +1877,9 @@ define Image/Build/OpenMesh
|
|
"$(BUILD_DIR)/fwupgrade.cfg-$(4)" "fwupgrade.cfg" \
|
|
"$(KDIR_TMP)/vmlinux-$(2).uImage" "kernel" \
|
|
"$(KDIR)/root.$(1)" "rootfs"
|
|
+ if [ -e "$(call factoryname,$(1),$(2))" ]; then \
|
|
+ cp "$(call factoryname,$(1),$(2))" "$(call sysupname,$(1),$(2))"; \
|
|
+ fi
|
|
endef
|
|
|
|
|