36 lines
1.2 KiB
Diff
36 lines
1.2 KiB
Diff
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Sun, 21 Jun 2015 22:48:04 +0200
|
|
Subject: ar71xx: add support for TL-WR741ND v5
|
|
|
|
This device is identical to the TL-WR740N v5, it even uses the same HWID (which
|
|
wasn't the case for older TL-WR741ND revisions).
|
|
|
|
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
|
|
index 8fc9f4c..b45f9b2 100644
|
|
--- a/target/linux/ar71xx/image/Makefile
|
|
+++ b/target/linux/ar71xx/image/Makefile
|
|
@@ -506,6 +506,14 @@ define Device/tl-wr741nd-v4
|
|
CONSOLE := ttyATH0,115200
|
|
endef
|
|
|
|
+define Device/tl-wr741nd-v5
|
|
+ $(Device/tplink-4mlzma)
|
|
+ BOARDNAME := TL-WR741ND-v4
|
|
+ DEVICE_PROFILE := TLWR741
|
|
+ TPLINK_HWID := 0x07400005
|
|
+ CONSOLE := ttyATH0,115200
|
|
+endef
|
|
+
|
|
define Device/tl-wr743nd-v2
|
|
$(Device/tplink-4mlzma)
|
|
BOARDNAME := TL-WR741ND-v4
|
|
@@ -513,7 +521,7 @@ define Device/tl-wr743nd-v2
|
|
TPLINK_HWID := 0x07430002
|
|
CONSOLE := ttyATH0,115200
|
|
endef
|
|
-TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
|
|
+TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr741nd-v5 tl-wr743nd-v2
|
|
|
|
define Device/tl-wr841n-v8
|
|
$(Device/tplink-4mlzma)
|