25 lines
890 B
Diff
25 lines
890 B
Diff
From: Martin Weinelt <martin@darmstadt.freifunk.net>
|
|
Date: Tue, 8 Feb 2022 21:09:20 +0100
|
|
Subject: perl: don't build in parallel and bump release
|
|
|
|
Parallel builds cause spurious build failures with high core counts.
|
|
|
|
https://github.com/openwrt/packages/issues/8238
|
|
https://github.com/openwrt/packages/pull/17274
|
|
|
|
diff --git a/lang/perl/Makefile b/lang/perl/Makefile
|
|
index 99302cb1a4414c309b238342d3f1b8bc7f43dd47..66c6ce7aaf342e404b8d9a133a7e396d0108a31f 100644
|
|
--- a/lang/perl/Makefile
|
|
+++ b/lang/perl/Makefile
|
|
@@ -34,8 +34,8 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/perl/$(PKG_NAME)-$(PKG_VERSION)
|
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/perl/$(PKG_NAME)-$(PKG_VERSION)
|
|
PKG_INSTALL:=1
|
|
PKG_BUILD_DEPENDS:=perl/host
|
|
-PKG_BUILD_PARALLEL:=1
|
|
-HOST_BUILD_PARALLEL:=1
|
|
+PKG_BUILD_PARALLEL:=0
|
|
+HOST_BUILD_PARALLEL:=0
|
|
|
|
# Variables used during configuration/build
|
|
HOST_PERL_PREFIX:=$(STAGING_DIR_HOSTPKG)/usr
|