8b35fab23e
00d7702796 mac80211: Update to version 5.15.74-1
7a3d5959af ath79: fix reference clock for RouterBoard 912UAG
b5cb5f352d ramips: fix WAN mac address allocation for Unielec 01 and 06 models
ef5b1ffb9e ramips: rt3883: enable lzma-loader for Belkin F9K1109v1
b0ab21d9d0 ramips: mt7621: enable lzma-loader for Asus RT-N56U-B1
40465adbbf bcm53xx: enable Broadcom 4366b1 firmware for Asus RT-AC88U
b37ff14302 wireless-tools: add package CPE ID
69e6486136 ncurses: add package CPE ID
573606991e arm-trusted-firmware-sunxi: add package CPE ID
714345d35a libnftnl: add package CPE ID
e946d9aa9d octeon: fix imagebuilder generation by introducing generic target
6cffcb2e9f ath79: support Ruckus ZoneFlex 7321
85a7588c90 ath79: support Ruckus ZoneFlex 7372
08969f61b0 kernel: add kmod-nvme package
c1c85629b9 kernel: mtd: fix unbalanced of_node_put() in dynamic partitions code
5c0c01d226 kernel: bump 5.10 to 5.10.149
980aad01d1 kernel: bump 5.10 to 5.10.148
fb11c63511 kernel: bump 5.10 to 5.10.147
8fefd5c26c mt7621: hiwifi_hc5962: fix reboot loop by using LZMA loader
f59dcb92cf ucode: update to latest Git HEAD
f1d7f1c70f firewall4: update to latest Git HEAD
36a808b7bc mt7621: netgear_ex6150: fix reboot loop by using LZMA loader
12acecd114 OpenWrt v22.03.2: revert to branch defaults
ea845f76ea OpenWrt v22.03.2: adjust config defaults
9a599fee93 firewall4: update to latest Git HEAD
30de1b5031 ucode: update to latest Git HEAD
fa4ec03993 rpcd: update to latest Git HEAD
(cherry picked from commit 1a7acd4699
)
73 lines
2.1 KiB
Diff
73 lines
2.1 KiB
Diff
From: David Bauer <mail@david-bauer.net>
|
|
Date: Sun, 5 Jun 2022 23:43:38 +0200
|
|
Subject: ramips-mt7621: make DSA images swconfig upgradable
|
|
|
|
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
|
|
index 94b040e361c89e7363116e461ec4f678854f64f3..8327f8653b65f18814ecea2096b0516c4a144515 100644
|
|
--- a/target/linux/ramips/image/mt7621.mk
|
|
+++ b/target/linux/ramips/image/mt7621.mk
|
|
@@ -179,7 +179,6 @@ endef
|
|
TARGET_DEVICES += asiarf_ap7621-nv1
|
|
|
|
define Device/asus_rt-ac57u
|
|
- $(Device/dsa-migration)
|
|
DEVICE_VENDOR := ASUS
|
|
DEVICE_MODEL := RT-AC57U
|
|
DEVICE_ALT0_VENDOR := ASUS
|
|
@@ -426,7 +425,6 @@ endef
|
|
TARGET_DEVICES += dlink_dir-853-r1
|
|
|
|
define Device/dlink_dir-860l-b1
|
|
- $(Device/dsa-migration)
|
|
$(Device/seama)
|
|
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
|
|
LOADER_TYPE := bin
|
|
@@ -1236,7 +1234,6 @@ endef
|
|
TARGET_DEVICES += mts_wg430223
|
|
|
|
define Device/netgear_ex6150
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
DEVICE_VENDOR := NETGEAR
|
|
DEVICE_MODEL := EX6150
|
|
@@ -1249,7 +1246,6 @@ endef
|
|
TARGET_DEVICES += netgear_ex6150
|
|
|
|
define Device/netgear_sercomm_nand
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
BLOCKSIZE := 128k
|
|
PAGESIZE := 2048
|
|
@@ -1432,7 +1428,6 @@ endef
|
|
TARGET_DEVICES += netgear_wax202
|
|
|
|
define Device/netgear_wndr3700-v5
|
|
- $(Device/dsa-migration)
|
|
$(Device/netgear_sercomm_nor)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 15232k
|
|
@@ -1756,7 +1751,6 @@ endef
|
|
TARGET_DEVICES += tplink_tl-wpa8631p-v3
|
|
|
|
define Device/ubnt_edgerouter_common
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
DEVICE_VENDOR := Ubiquiti
|
|
IMAGE_SIZE := 256768k
|
|
@@ -2153,7 +2147,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg2626
|
|
|
|
define Device/zbtlink_zbt-wg3526-16m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 16064k
|
|
DEVICE_VENDOR := Zbtlink
|
|
@@ -2166,7 +2159,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
|
|
|
|
define Device/zbtlink_zbt-wg3526-32m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 32448k
|
|
DEVICE_VENDOR := Zbtlink
|