gluon/patches/openwrt/0004-ramips-mt7621-make-DSA-images-swconfig-upgradable.patch
Jan-Niklas Burfeind b9d6a64eee modules: update openwrt
6cd1035d8d ramips: add support for Wavlink WS-WN572HP3 4G
3f7ce4bd40 comgt-ncm: add support for quectel modem EC200T-EU
03ab5a60da realtek: update GPIO bindings for DGS-1210-10P
63fde4607c ustream-ssl: update to Git version 2022-12-07
1c174fe0ba CI: kernel: don't checkout and install feeds
385f78780c CI: build: skip sdk adapt to external toolchain on cache hit
8be50c369b CI: build: fix use of sdk as toolchain
1af58a2d39 ramips: mt7621: enable lzma-loader for ZyXEL WAP6805
8fbf03690e ramips: mt7621: enable lzma-loader for netis WF2881
282dd271ad kernel: ca8210: Fix crash by zero initializing data
1a0f2c3a3e e2fsprogs: Fix CVE-2022-1304
1285938d2c bcm4908: Refresh kernel patches
2022-12-09 00:32:56 +01:00

65 lines
1.8 KiB
Diff

From: David Bauer <mail@david-bauer.net>
Date: Sun, 5 Jun 2022 23:43:38 +0200
Subject: ramips-mt7621: make DSA images swconfig upgradable
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 961f8a3b7514a3658f8d4795c136d5069830126f..982ca6b9196853df2ab5070c26f175ade6567eaa 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -179,7 +179,6 @@ endef
TARGET_DEVICES += asiarf_ap7621-nv1
define Device/asus_rt-ac57u
- $(Device/dsa-migration)
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC57U
DEVICE_ALT0_VENDOR := ASUS
@@ -1233,7 +1232,6 @@ endef
TARGET_DEVICES += mts_wg430223
define Device/netgear_ex6150
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX6150
@@ -1246,7 +1244,6 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -1429,7 +1426,6 @@ endef
TARGET_DEVICES += netgear_wax202
define Device/netgear_wndr3700-v5
- $(Device/dsa-migration)
$(Device/netgear_sercomm_nor)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 15232k
@@ -1754,7 +1750,6 @@ endef
TARGET_DEVICES += tplink_tl-wpa8631p-v3
define Device/ubnt_edgerouter_common
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
@@ -2170,7 +2165,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg2626
define Device/zbtlink_zbt-wg3526-16m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
@@ -2183,7 +2177,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
define Device/zbtlink_zbt-wg3526-32m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Zbtlink