gluon/patches/openwrt/0004-ramips-mt7621-make-DSA-images-swconfig-upgradable.patch
David Bauer 91df13c8b1 modules: update openwrt
b472753d79 mediatek: fix Unifi 6LR network config
c0b7b2049e mpc85xx: fix unset kernel symbols
7c459ac1d5 mac80211: rt2x00: experimental improvements for MT7620 wifi
d004110ef7 mac80211: rt2x00: fix typo
0755c18ff1 mac80211: add patch descriptions to rt2x00 patches
7a26f40217 mediatek: fix ledbar of UniFi 6 LR when running custom U-Boot
f54d4ea0bb ramips: add support for Ubiquiti UniFi FlexHD
a28ccd58ed ath79: Make patches apply again
2419546cee generic: move ledbar driver from mediatek target
420a86436f mediatek: add led count
40610c5322 mediatek: add initialization after reset
26cd0c1ee9 mediatek: add support for reset gpio
b5665a0045 mediatek: support reading more than one byte of response
cd0283788f mediatek: cast literal value to char
a2d251573b mediatek: correctly log i2c response
7366ee86ef mediatek: remove gpiod_direction_output()
ba6c780acb mediatek: do not use gpiod_set_raw_value()
745d3cd4aa kernel: modules: package kmod-crypto-essiv
a3f9b42789 mediatek: fix typo in bpi-r64 image recipe
29c5d5d3da mediatek: bpi-r64: make initramfs/recovery optional
d10352917b ramips: fix GB-PC1 and GB-PC2 LEDs
0c9833d0e0 wireless-regdb: update to 2022-08-12
be4abbd84a kernel: bump 5.10 to 5.10.143
4e05e7dddf kernel: bump 5.10 to 5.10.142
1b0db300cb kernel: bump 5.10 to 5.10.141
bf65d2dcba kernel: bump 5.10 to 5.10.139
e7ef88ff1d kernel: build crypto md5/sha1/sha256 modules for powerpc
2022-09-20 21:28:47 +02:00

73 lines
2.1 KiB
Diff

From: David Bauer <mail@david-bauer.net>
Date: Sun, 5 Jun 2022 23:43:38 +0200
Subject: ramips-mt7621: make DSA images swconfig upgradable
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8860be11b8c879c067901cf6642a133b27b1e3b2..f8a846cfc67c306fedfbdb2bd2056fa3d6aa1b61 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -172,7 +172,6 @@ endef
TARGET_DEVICES += asiarf_ap7621-nv1
define Device/asus_rt-ac57u
- $(Device/dsa-migration)
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC57U
DEVICE_ALT0_VENDOR := ASUS
@@ -418,7 +417,6 @@ endef
TARGET_DEVICES += dlink_dir-853-r1
define Device/dlink_dir-860l-b1
- $(Device/dsa-migration)
$(Device/seama)
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
LOADER_TYPE := bin
@@ -1226,7 +1224,6 @@ endef
TARGET_DEVICES += mts_wg430223
define Device/netgear_ex6150
- $(Device/dsa-migration)
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX6150
DEVICE_PACKAGES := kmod-mt76x2
@@ -1238,7 +1235,6 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -1421,7 +1417,6 @@ endef
TARGET_DEVICES += netgear_wax202
define Device/netgear_wndr3700-v5
- $(Device/dsa-migration)
$(Device/netgear_sercomm_nor)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 15232k
@@ -1745,7 +1740,6 @@ endef
TARGET_DEVICES += tplink_tl-wpa8631p-v3
define Device/ubnt_edgerouter_common
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
@@ -2142,7 +2136,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg2626
define Device/zbtlink_zbt-wg3526-16m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
@@ -2155,7 +2148,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
define Device/zbtlink_zbt-wg3526-32m
- $(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Zbtlink