af579e9906
ecd8f7e294 ramips: get MAC addr from the encrypted partition (WG4хх223) 290ace2fe6 base-files: add mtd_get_mac_encrypted_arcadyan function d94a28f7d2 uencrypt: add package to decrypt WG4хх223 config bfb37d363c odhcp6c: update to git HEAD 464f349fad ramips: allow custom trx magic for Arcadyan 7edaae16db ramips: create new dtsi for Arcadyan routers 206581018c ramips: add support for MTS WG430223 1320a78aab ramips: add support for ASUS RT-AX53U e06f97eb33 mvebu: backport pending Turris Omnia LEDs improvements 93ac163dea mvebu: backport DTS changes for Turris Omnia from mvebu/dt 659bb7638d mpc85xx: enable NAND support for all subtargets 89b7714cf6 kernel: add kmod-leds-turris-omnia 5e39f37caa toolchain: Update glibc 2.34 to recent HEAD da7e9b201e build: add support for python3.11 and higher dfe5c23592 iwinfo: update to latest HEAD 1d16b928b3 ath25: fix initramfs image generation 2728d13030 ath25: fix ELF image generation 46e62907f1 kernel: bump 5.10 to 5.10.136 be29de706c kernel: bump 5.10 to 5.10.135 6c901ec97d kernel: Backport upstream flowtable patches from 5.15 6a638c134d pkg-config: always use correct path for pkg-config.real 1c7a167366 kernel: kmod-phy-smsc: Add new PHY fd4a354f3e kernel: kmod-phy-ax88796b: Add new PHY 13d66ef33f kernel: kmod-ipt-ulog: Remove package 534e256c02 kernel: kmod-nft-nat6: Remove package 2a6fa77b77 kernel: ipt-ipset: Add ipset/ip_set_hash_ipmac.ko fc05102d51 kernel: netsupport: kmod-sched: explicitly define included modules 3b51f74a91 kernel: netsupport: kmod-sched: Add kmod-lib-textsearch dependency 9727b71147 kernel: netsupport: kmod-sched: Remove sch_fq_codel and sch_fifo 0038e96c27 arm-trusted-firmware-mediatek: skip bad blocks on SPI-NAND (SNFI) 5c69416246 fstools: add uci fstab section to conffiles for package block-mount 0855549b4b kernel: scale nf_conntrack_max more reasonably 0179ba7851 dnsmasq: fix jail_mount for serversfile
73 lines
2.1 KiB
Diff
73 lines
2.1 KiB
Diff
From: David Bauer <mail@david-bauer.net>
|
|
Date: Sun, 5 Jun 2022 23:43:38 +0200
|
|
Subject: ramips-mt7621: make DSA images swconfig upgradable
|
|
|
|
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
|
|
index e3608d8d4e464146d88bdcd8efdd6ec870823fb7..c85a6f90bd4efffee6d05cd43759a1c8578477ac 100644
|
|
--- a/target/linux/ramips/image/mt7621.mk
|
|
+++ b/target/linux/ramips/image/mt7621.mk
|
|
@@ -172,7 +172,6 @@ endef
|
|
TARGET_DEVICES += asiarf_ap7621-nv1
|
|
|
|
define Device/asus_rt-ac57u
|
|
- $(Device/dsa-migration)
|
|
DEVICE_VENDOR := ASUS
|
|
DEVICE_MODEL := RT-AC57U
|
|
DEVICE_ALT0_VENDOR := ASUS
|
|
@@ -418,7 +417,6 @@ endef
|
|
TARGET_DEVICES += dlink_dir-853-r1
|
|
|
|
define Device/dlink_dir-860l-b1
|
|
- $(Device/dsa-migration)
|
|
$(Device/seama)
|
|
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
|
|
LOADER_TYPE := bin
|
|
@@ -1224,7 +1222,6 @@ endef
|
|
TARGET_DEVICES += mts_wg430223
|
|
|
|
define Device/netgear_ex6150
|
|
- $(Device/dsa-migration)
|
|
DEVICE_VENDOR := NETGEAR
|
|
DEVICE_MODEL := EX6150
|
|
DEVICE_PACKAGES := kmod-mt76x2
|
|
@@ -1236,7 +1233,6 @@ endef
|
|
TARGET_DEVICES += netgear_ex6150
|
|
|
|
define Device/netgear_sercomm_nand
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
BLOCKSIZE := 128k
|
|
PAGESIZE := 2048
|
|
@@ -1419,7 +1415,6 @@ endef
|
|
TARGET_DEVICES += netgear_wax202
|
|
|
|
define Device/netgear_wndr3700-v5
|
|
- $(Device/dsa-migration)
|
|
$(Device/netgear_sercomm_nor)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 15232k
|
|
@@ -1743,7 +1738,6 @@ endef
|
|
TARGET_DEVICES += tplink_tl-wpa8631p-v3
|
|
|
|
define Device/ubnt_edgerouter_common
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
DEVICE_VENDOR := Ubiquiti
|
|
IMAGE_SIZE := 256768k
|
|
@@ -2129,7 +2123,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg2626
|
|
|
|
define Device/zbtlink_zbt-wg3526-16m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 16064k
|
|
DEVICE_VENDOR := Zbtlink
|
|
@@ -2142,7 +2135,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
|
|
|
|
define Device/zbtlink_zbt-wg3526-32m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 32448k
|
|
DEVICE_VENDOR := Zbtlink
|