1fa9c28d4d
d1f14d17aa ramips: fix GB-PC1 and GB-PC2 device support 0197cc553a hostapd: fix WPA3 enterprise keys and ciphers 567f64df57 iwinfo: update to latest HEAD f543588812 iproute2: Fix KERNEL_INCLUDE in SDK 8de88a2aa9 umbim: bump to git HEAD e0832778a3 mt76: update to the latest version da3dc96b64 netifd: update to the latest version 237f8e2cfc netifd: update to git HEAD 8a9733ee0d rpcd: bump version to 2022-08-24 8f4a2e4234 rpcd: update to latest Git HEAD f92ac40ebd uhttpd: update to latest Git HEAD d4f20964ff ucode: update to latest Git HEAD 469db326ac nftables: fix parsing date expressions fd268e3973 firewall4: update to latest Git HEAD 296c9aeb39 ipq806x: add missing scaling_available_frequencies for dedicated cpufreq 97213c7335 mac80211: parse the correct set of HE capabilities for AP mode
73 lines
2.1 KiB
Diff
73 lines
2.1 KiB
Diff
From: David Bauer <mail@david-bauer.net>
|
|
Date: Sun, 5 Jun 2022 23:43:38 +0200
|
|
Subject: ramips-mt7621: make DSA images swconfig upgradable
|
|
|
|
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
|
|
index 7f903485aa9e3055ae0bb490bb8e6d5aab565b45..5b502710b7959825bc2e079d0ffcbbe9c1b063ae 100644
|
|
--- a/target/linux/ramips/image/mt7621.mk
|
|
+++ b/target/linux/ramips/image/mt7621.mk
|
|
@@ -172,7 +172,6 @@ endef
|
|
TARGET_DEVICES += asiarf_ap7621-nv1
|
|
|
|
define Device/asus_rt-ac57u
|
|
- $(Device/dsa-migration)
|
|
DEVICE_VENDOR := ASUS
|
|
DEVICE_MODEL := RT-AC57U
|
|
DEVICE_ALT0_VENDOR := ASUS
|
|
@@ -418,7 +417,6 @@ endef
|
|
TARGET_DEVICES += dlink_dir-853-r1
|
|
|
|
define Device/dlink_dir-860l-b1
|
|
- $(Device/dsa-migration)
|
|
$(Device/seama)
|
|
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
|
|
LOADER_TYPE := bin
|
|
@@ -1226,7 +1224,6 @@ endef
|
|
TARGET_DEVICES += mts_wg430223
|
|
|
|
define Device/netgear_ex6150
|
|
- $(Device/dsa-migration)
|
|
DEVICE_VENDOR := NETGEAR
|
|
DEVICE_MODEL := EX6150
|
|
DEVICE_PACKAGES := kmod-mt76x2
|
|
@@ -1238,7 +1235,6 @@ endef
|
|
TARGET_DEVICES += netgear_ex6150
|
|
|
|
define Device/netgear_sercomm_nand
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
BLOCKSIZE := 128k
|
|
PAGESIZE := 2048
|
|
@@ -1421,7 +1417,6 @@ endef
|
|
TARGET_DEVICES += netgear_wax202
|
|
|
|
define Device/netgear_wndr3700-v5
|
|
- $(Device/dsa-migration)
|
|
$(Device/netgear_sercomm_nor)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 15232k
|
|
@@ -1745,7 +1740,6 @@ endef
|
|
TARGET_DEVICES += tplink_tl-wpa8631p-v3
|
|
|
|
define Device/ubnt_edgerouter_common
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
DEVICE_VENDOR := Ubiquiti
|
|
IMAGE_SIZE := 256768k
|
|
@@ -2131,7 +2125,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg2626
|
|
|
|
define Device/zbtlink_zbt-wg3526-16m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 16064k
|
|
DEVICE_VENDOR := Zbtlink
|
|
@@ -2144,7 +2137,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
|
|
|
|
define Device/zbtlink_zbt-wg3526-32m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 32448k
|
|
DEVICE_VENDOR := Zbtlink
|