99471f8d5d
Closes #844
236 lines
8.9 KiB
Diff
236 lines
8.9 KiB
Diff
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Thu, 5 Jan 2017 16:01:17 +0100
|
|
Subject: ar71xx: add support for TP-Link WBS210/510
|
|
|
|
The devices are mostly identical to the CPE210/510, but use external
|
|
antennas.
|
|
|
|
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
|
|
Backport of LEDE 1fef80f29cf6bdfcb6cdbd913b9147797b8bc218
|
|
|
|
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/01_gpio-switches b/target/linux/ar71xx/base-files/etc/uci-defaults/01_gpio-switches
|
|
index 0f7a41589384755ff596d4355ad9fbf1e1087d91..3b86067635e337a0c00a55d035d55382405ef1e7 100644
|
|
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/01_gpio-switches
|
|
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/01_gpio-switches
|
|
@@ -16,7 +16,9 @@ nanostation-m-xw)
|
|
ucidef_set_gpio_switch "poe_passthrough" "PoE Passthrough" "2"
|
|
;;
|
|
cpe210|\
|
|
-cpe510)
|
|
+cpe510|\
|
|
+wbs210|\
|
|
+wbs510)
|
|
ucidef_set_gpio_switch "poe_passthrough" "PoE Passthrough" "20"
|
|
;;
|
|
esac
|
|
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
|
|
index fa38568fbc84aad4c85636c3894097c65e30eb9a..d57d8ad5fd3edd8774d30245b3265317778cb140 100644
|
|
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
|
|
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
|
|
@@ -79,7 +79,9 @@ carambola2)
|
|
;;
|
|
|
|
cpe210|\
|
|
-cpe510)
|
|
+cpe510|\
|
|
+wbs210|\
|
|
+wbs510)
|
|
ucidef_set_led_switch "lan0" "LAN0" "tp-link:green:lan0" "switch0" "0x20"
|
|
ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
|
|
ucidef_set_rssimon "wlan0" "200000" "1"
|
|
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
|
|
index 4389bc894f8dd08a9231b35bbb4fba0e9e57560b..f8c43ac0d6f2882444ed277df2f0b2c23721dade 100755
|
|
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
|
|
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
|
|
@@ -73,7 +73,9 @@ bsb)
|
|
;;
|
|
|
|
cpe210|\
|
|
-cpe510)
|
|
+cpe510|\
|
|
+wbs210|\
|
|
+wbs510)
|
|
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
|
|
ucidef_add_switch "switch0" "1" "1"
|
|
ucidef_add_switch_vlan "switch0" "1" "0t 5"
|
|
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
|
|
index 5922527da4980fa3b51fdcec2bca96f5962d0f0b..33fdc751034d8cbdec344211f4e2b10afa0e9849 100755
|
|
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
|
|
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
|
|
@@ -444,6 +444,14 @@ ar71xx_board_detect() {
|
|
name="cpe510"
|
|
tplink_pharos_board_detect
|
|
;;
|
|
+ *WBS210)
|
|
+ name="wbs210"
|
|
+ tplink_pharos_board_detect
|
|
+ ;;
|
|
+ *WBS510)
|
|
+ name="wbs510"
|
|
+ tplink_pharos_board_detect
|
|
+ ;;
|
|
*"DB120 reference board")
|
|
name="db120"
|
|
;;
|
|
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
|
|
index e61ebf7c2221fd56bb902f14d96cb25d174718ee..a4e37e24cc57da5e90a86a1a5a99c6dfc829e65f 100755
|
|
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
|
|
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
|
|
@@ -266,7 +266,9 @@ platform_check_image() {
|
|
;;
|
|
|
|
cpe210|\
|
|
- cpe510)
|
|
+ cpe510|\
|
|
+ wbs210|\
|
|
+ wbs510)
|
|
tplink_pharos_check_image "$1" && return 0
|
|
return 1
|
|
;;
|
|
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-cpe510.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-cpe510.c
|
|
index 74daf434e611d1f9d05f7d7516ae918d334b32b7..d2dbed1fe286c44d3188262e984253faaee7edba 100644
|
|
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-cpe510.c
|
|
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-cpe510.c
|
|
@@ -30,6 +30,9 @@
|
|
#define CPE510_GPIO_LED_L3 15
|
|
#define CPE510_GPIO_LED_L4 16
|
|
|
|
+/* All LEDs/button except for link4 are the same for CPE and WBS series */
|
|
+#define WBS510_GPIO_LED_L4 2
|
|
+
|
|
#define CPE510_GPIO_EXTERNAL_LNA0 18
|
|
#define CPE510_GPIO_EXTERNAL_LNA1 19
|
|
|
|
@@ -67,6 +70,34 @@ static struct gpio_led cpe510_leds_gpio[] __initdata = {
|
|
},
|
|
};
|
|
|
|
+static struct gpio_led wbs510_leds_gpio[] __initdata = {
|
|
+ {
|
|
+ .name = "tp-link:green:lan0",
|
|
+ .gpio = CPE510_GPIO_LED_LAN0,
|
|
+ .active_low = 1,
|
|
+ }, {
|
|
+ .name = "tp-link:green:lan1",
|
|
+ .gpio = CPE510_GPIO_LED_LAN1,
|
|
+ .active_low = 1,
|
|
+ }, {
|
|
+ .name = "tp-link:green:link1",
|
|
+ .gpio = CPE510_GPIO_LED_L1,
|
|
+ .active_low = 1,
|
|
+ }, {
|
|
+ .name = "tp-link:green:link2",
|
|
+ .gpio = CPE510_GPIO_LED_L2,
|
|
+ .active_low = 1,
|
|
+ }, {
|
|
+ .name = "tp-link:green:link3",
|
|
+ .gpio = CPE510_GPIO_LED_L3,
|
|
+ .active_low = 1,
|
|
+ }, {
|
|
+ .name = "tp-link:green:link4",
|
|
+ .gpio = WBS510_GPIO_LED_L4,
|
|
+ .active_low = 1,
|
|
+ },
|
|
+};
|
|
+
|
|
static struct gpio_keys_button cpe510_gpio_keys[] __initdata = {
|
|
{
|
|
.desc = "Reset button",
|
|
@@ -85,9 +116,6 @@ static void __init cpe_setup(u8 *mac)
|
|
ath79_gpio_function_setup(AR934X_GPIO_FUNC_JTAG_DISABLE,
|
|
AR934X_GPIO_FUNC_CLK_OBS4_EN);
|
|
|
|
- ath79_register_leds_gpio(-1, ARRAY_SIZE(cpe510_leds_gpio),
|
|
- cpe510_leds_gpio);
|
|
-
|
|
ath79_register_gpio_keys_polled(1, CPE510_KEYS_POLL_INTERVAL,
|
|
ARRAY_SIZE(cpe510_gpio_keys),
|
|
cpe510_gpio_keys);
|
|
@@ -109,6 +137,9 @@ static void __init cpe210_setup(void)
|
|
u8 *mac = (u8 *) KSEG1ADDR(0x1f830008);
|
|
u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
|
|
|
|
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(cpe510_leds_gpio),
|
|
+ cpe510_leds_gpio);
|
|
+
|
|
cpe_setup(mac);
|
|
|
|
ath79_register_wmac(ee, mac);
|
|
@@ -119,6 +150,22 @@ static void __init cpe510_setup(void)
|
|
u8 *mac = (u8 *) KSEG1ADDR(0x1f830008);
|
|
u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
|
|
|
|
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(cpe510_leds_gpio),
|
|
+ cpe510_leds_gpio);
|
|
+
|
|
+ cpe_setup(mac);
|
|
+
|
|
+ ath79_register_wmac(ee, mac);
|
|
+}
|
|
+
|
|
+static void __init wbs_setup(void)
|
|
+{
|
|
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f830008);
|
|
+ u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
|
|
+
|
|
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(wbs510_leds_gpio),
|
|
+ wbs510_leds_gpio);
|
|
+
|
|
cpe_setup(mac);
|
|
|
|
ath79_register_wmac(ee, mac);
|
|
@@ -129,3 +176,9 @@ MIPS_MACHINE(ATH79_MACH_CPE210, "CPE210", "TP-LINK CPE210/220",
|
|
|
|
MIPS_MACHINE(ATH79_MACH_CPE510, "CPE510", "TP-LINK CPE510/520",
|
|
cpe510_setup);
|
|
+
|
|
+MIPS_MACHINE(ATH79_MACH_WBS210, "WBS210", "TP-LINK WBS210",
|
|
+ wbs_setup);
|
|
+
|
|
+MIPS_MACHINE(ATH79_MACH_WBS510, "WBS510", "TP-LINK WBS510",
|
|
+ wbs_setup);
|
|
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
|
|
index 61e221255f6742f9594da168b11af7716d6a720e..459373b9cb96097d155b3d8f4e5fb76701d46d1c 100644
|
|
--- a/target/linux/ar71xx/image/Makefile
|
|
+++ b/target/linux/ar71xx/image/Makefile
|
|
@@ -2166,6 +2166,8 @@ $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR2543,tl-wr2543-v1,TL-WR2543N,
|
|
|
|
$(eval $(call SingleProfile,TPLINK-SAFELOADER,64kraw,CPE210_220,cpe210-220,CPE210,ttyS0,115200,$$(cpe510_mtdlayout),CPE210))
|
|
$(eval $(call SingleProfile,TPLINK-SAFELOADER,64kraw,CPE510_520,cpe510-520,CPE510,ttyS0,115200,$$(cpe510_mtdlayout),CPE510))
|
|
+$(eval $(call SingleProfile,TPLINK-SAFELOADER,64kraw,WBS210,wbs210,WBS210,ttyS0,115200,$$(cpe510_mtdlayout),WBS210))
|
|
+$(eval $(call SingleProfile,TPLINK-SAFELOADER,64kraw,WBS510,wbs510,WBS510,ttyS0,115200,$$(cpe510_mtdlayout),WBS510))
|
|
|
|
$(eval $(call SingleProfile,UAPPRO,64k,UAPPRO,ubnt-uap-pro,UAP-PRO,ttyS0,115200,BZ,BZ,ar934x))
|
|
$(eval $(call SingleProfile,UAPPRO,64k,UBNTUNIFIOUTDOORPLUS,ubnt-unifi-outdoor-plus,UBNT-UOP,ttyS0,115200,BZ,BZ,ar7240))
|
|
@@ -2229,7 +2231,7 @@ $(eval $(call MultiProfile,TLWR842,TLWR842V1))
|
|
$(eval $(call MultiProfile,TLWR941,TLWR941NV2 TLWR941NV3 TLWR941NV4))
|
|
$(eval $(call MultiProfile,TLWR1043,TLWR1043V1 TLWR1043V2 TLWR1043V3))
|
|
$(eval $(call MultiProfile,TLWDR4300,TLWDR3500V1 TLWDR3600V1 TLWDR4300V1 TLWDR4300V1IL TLWDR4310V1 MW4530RV1))
|
|
-$(eval $(call MultiProfile,CPE510,CPE210_220 CPE510_520))
|
|
+$(eval $(call MultiProfile,CPE510,CPE210_220 CPE510_520 WBS210 WBS510))
|
|
$(eval $(call MultiProfile,TUBE2H,TUBE2H8M TUBE2H16M))
|
|
$(eval $(call MultiProfile,UBNT,UBNTAIRROUTER UBNTRS UBNTRSPRO UBNTLSSR71 UBNTBULLETM UBNTROCKETM UBNTROCKETMXW UBNTNANOM UBNTNANOMXW UBNTLOCOXW UBNTUNIFI UBNTUNIFIOUTDOOR UBNTUNIFIOUTDOORPLUS UAPPRO UBNTAIRGW))
|
|
$(eval $(call MultiProfile,WNR612V2,REALWNR612V2 N150R))
|
|
diff --git a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
|
|
index fb69cf3b9ee51e39c32a9e98de913c1a84bed56a..93ae596bfd9f439daf9295e3d58858c3067160b9 100644
|
|
--- a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
|
|
+++ b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
|
|
@@ -1,6 +1,6 @@
|
|
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
-@@ -16,22 +16,207 @@
|
|
+@@ -16,22 +16,209 @@
|
|
|
|
enum ath79_mach_type {
|
|
ATH79_MACH_GENERIC = 0,
|
|
@@ -175,6 +175,8 @@
|
|
ATH79_MACH_UBNT_UNIFI_OUTDOOR, /* Ubiquiti UnifiAP Outdoor */
|
|
+ ATH79_MACH_UBNT_UNIFI_OUTDOOR_PLUS, /* Ubiquiti UnifiAP Outdoor+ */
|
|
ATH79_MACH_UBNT_XM, /* Ubiquiti Networks XM board rev 1.0 */
|
|
++ ATH79_MACH_WBS210, /* TP-LINK WBS210 */
|
|
++ ATH79_MACH_WBS510, /* TP-LINK WBS510 */
|
|
+ ATH79_MACH_WEIO, /* WeIO board */
|
|
+ ATH79_MACH_WHR_G301N, /* Buffalo WHR-G301N */
|
|
+ ATH79_MACH_WHR_HP_G300N, /* Buffalo WHR-HP-G300N */
|