07e83438c1
8c1f8f9978 ipq40xx: ZTE MF286D: fix DEVICE_PACKAGES 54dc60e71d generic: fix unset symbol c837fc9cdb kernel: bump 5.10 to 5.10.154 bbad2ee4de kernel: bump 5.10 to 5.10.153 d2ae7613b5 ramips: improve compatibility for Youku YK-L2 and YK-L1 series 9155d40513 ramips: gl-mt1300: downclock SPI to 50MHz ca124d2e4b ramips: mt7621: use seama-lzma-loader for D-Link DIR-860L B1 fafc9448ae ramips: rt3883: use seama-lzma-loader for D-Link DIR-645 292d3f00c7 ramips: define lzma-loader recipe for SEAMA devices d25e1a3bde ath79: fix MAC address assignment for TP-Link ar7241 devices 7fa6351310 tools/expat: update to 2.5.0 8122aa92fd ath79: add support for Linksys EA4500 v3 1133a8f805 ath79: add support to TrendNet TEW-673GRU 5725b773b4 qoriq: fix typo in FEATURES 615dbec223 mac80211: fix mesh airtime link metric estimation a26f7e61e8 mac80211: fix issues with receiving small STP packets bfeffb8aed mac80211: fix decap offload for stations on AP_VLAN interfaces 88c43b5887 hostapd: remove invalid dtim_period option processing
65 lines
1.8 KiB
Diff
65 lines
1.8 KiB
Diff
From: David Bauer <mail@david-bauer.net>
|
|
Date: Sun, 5 Jun 2022 23:43:38 +0200
|
|
Subject: ramips-mt7621: make DSA images swconfig upgradable
|
|
|
|
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
|
|
index 4057c4ea11b29233be7673a77fc2c8100209d8b3..c80d6e7f3aa0d1222aa087ba3cb11b8905a576b3 100644
|
|
--- a/target/linux/ramips/image/mt7621.mk
|
|
+++ b/target/linux/ramips/image/mt7621.mk
|
|
@@ -179,7 +179,6 @@ endef
|
|
TARGET_DEVICES += asiarf_ap7621-nv1
|
|
|
|
define Device/asus_rt-ac57u
|
|
- $(Device/dsa-migration)
|
|
DEVICE_VENDOR := ASUS
|
|
DEVICE_MODEL := RT-AC57U
|
|
DEVICE_ALT0_VENDOR := ASUS
|
|
@@ -1233,7 +1232,6 @@ endef
|
|
TARGET_DEVICES += mts_wg430223
|
|
|
|
define Device/netgear_ex6150
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
DEVICE_VENDOR := NETGEAR
|
|
DEVICE_MODEL := EX6150
|
|
@@ -1246,7 +1244,6 @@ endef
|
|
TARGET_DEVICES += netgear_ex6150
|
|
|
|
define Device/netgear_sercomm_nand
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
BLOCKSIZE := 128k
|
|
PAGESIZE := 2048
|
|
@@ -1429,7 +1426,6 @@ endef
|
|
TARGET_DEVICES += netgear_wax202
|
|
|
|
define Device/netgear_wndr3700-v5
|
|
- $(Device/dsa-migration)
|
|
$(Device/netgear_sercomm_nor)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 15232k
|
|
@@ -1753,7 +1749,6 @@ endef
|
|
TARGET_DEVICES += tplink_tl-wpa8631p-v3
|
|
|
|
define Device/ubnt_edgerouter_common
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
DEVICE_VENDOR := Ubiquiti
|
|
IMAGE_SIZE := 256768k
|
|
@@ -2152,7 +2147,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg2626
|
|
|
|
define Device/zbtlink_zbt-wg3526-16m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 16064k
|
|
DEVICE_VENDOR := Zbtlink
|
|
@@ -2165,7 +2159,6 @@ endef
|
|
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
|
|
|
|
define Device/zbtlink_zbt-wg3526-32m
|
|
- $(Device/dsa-migration)
|
|
$(Device/uimage-lzma-loader)
|
|
IMAGE_SIZE := 32448k
|
|
DEVICE_VENDOR := Zbtlink
|