bccfc0419e
The TL-WR741ND will identify itself as a TL-WR740N/ND as well. This is fine as the images are identical anyways.
40 lines
1.3 KiB
Diff
40 lines
1.3 KiB
Diff
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Sun, 21 Jun 2015 22:50:48 +0200
|
|
Subject: ar71xx: add support for tp-link wr740n v5.0 (EU)
|
|
|
|
TP-Link ships wr740n v5.0 to Romania (so probably everywhere except
|
|
China) with 4 MB flash and 32 MB memory (confirmed by their local
|
|
support). This patch adds support for the v5.0 clone of v4, i just
|
|
tested it on my own v5.0 router and it works.
|
|
|
|
Signed-off-by: Daniel Petre <daniel.petre@posteo.net>
|
|
|
|
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
|
|
index c8ed2ec..a233349 100644
|
|
--- a/target/linux/ar71xx/image/Makefile
|
|
+++ b/target/linux/ar71xx/image/Makefile
|
|
@@ -459,6 +459,14 @@ define Device/tl-wr740n-v4
|
|
CONSOLE := ttyATH0,115200
|
|
endef
|
|
|
|
+define Device/tl-wr740n-v5
|
|
+ $(Device/tplink-4mlzma)
|
|
+ BOARDNAME := TL-WR741ND-v4
|
|
+ DEVICE_PROFILE := TLWR740
|
|
+ TPLINK_HWID := 0x07400005
|
|
+ CONSOLE := ttyATH0,115200
|
|
+endef
|
|
+
|
|
define Device/tl-wr741nd-v1
|
|
$(Device/tplink-4m)
|
|
BOARDNAME := TL-WR741ND
|
|
@@ -488,7 +496,7 @@ define Device/tl-wr743nd-v2
|
|
TPLINK_HWID := 0x07430002
|
|
CONSOLE := ttyATH0,115200
|
|
endef
|
|
-TARGET_DEVICES += tl-wr740n-v4 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
|
|
+TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
|
|
|
|
define Device/tl-wr841n-v8
|
|
$(Device/tplink-4mlzma)
|