gluon/patches/openwrt/0021-opkg-work-around-unconditional-libopenssl-build-dependency.patch
2015-08-28 10:48:41 +02:00

23 lines
786 B
Diff

From: Matthias Schiffer <mschiffer@universe-factory.net>
Date: Fri, 28 Aug 2015 10:43:55 +0200
Subject: opkg: work around unconditional libopenssl build dependency
As the OpenWrt build system only resolves build dependencies per directory,
all opkg variants were causing libopenssl to be downloaded and built,
not only opkg-smime. Fix this by applying the same workaround as in
ustream-ssl.
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index d38ed52..16ff225 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -70,7 +70,7 @@ endef
define Package/opkg-smime
$(call Package/opkg/Default)
TITLE+= (with S/MIME signature support)
- DEPENDS+=+libopenssl
+ DEPENDS+=+PACKAGE_opkg-smime:libopenssl
VARIANT:=smime
endef