gluon/patches/openwrt/0120-prereq-backport-changes-to-git-detection-to-work-with-newer-Git-versions.patch

20 lines
986 B
Diff

From: Matthias Schiffer <mschiffer@universe-factory.net>
Date: Sun, 30 Jul 2017 21:03:05 +0200
Subject: prereq: backport changes to git detection to work with newer Git versions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index f36d57ce06c46be7ac33f3034ad08a3ce603089d..dbc273bcfe25f5ed6e24678462c0496e4c27ec31 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -144,8 +144,8 @@ $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
$(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
svn --version | grep Subversion))
-$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
- git clone 2>&1 | grep -- --recursive))
+$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
+ git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))