1f06d20705
We use our own firmware package.
73 lines
2.9 KiB
Diff
73 lines
2.9 KiB
Diff
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Tue, 9 Feb 2016 18:22:29 +0100
|
|
Subject: ath10k-firmware: add Candela Technologies firmware for QCA988X
|
|
|
|
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
|
|
index b03d644..7d4d449 100644
|
|
--- a/package/firmware/ath10k-firmware/Makefile
|
|
+++ b/package/firmware/ath10k-firmware/Makefile
|
|
@@ -44,6 +44,26 @@ define Download/ath10k-firmware-qca988x
|
|
endef
|
|
$(eval $(call Download,ath10k-firmware-qca988x))
|
|
|
|
+
|
|
+define Package/ath10k-firmware-qca988x-ct
|
|
+$(Package/ath10k-firmware-default)
|
|
+ TITLE:=ath10k firmware for QCA988x devices (Candela Technologies version)
|
|
+ CONFLICTS:=ath10k-firmware-qca988x
|
|
+endef
|
|
+
|
|
+QCA988X_CT_FIRMWARE_FILE:=firmware-5-ct-full-community.bin
|
|
+
|
|
+define Download/ath10k-firmware-qca988x-ct
|
|
+ # See http://www.candelatech.com/ath10k.php
|
|
+ #URL:=http://www.candelatech.com/downloads/ath10k-10-2/
|
|
+ # Update to beta version (will switch back to official URL after v2 release)
|
|
+ URL:=https://home.universe-factory.net/neoraider/
|
|
+ FILE:=$(QCA988X_CT_FIRMWARE_FILE)
|
|
+ MD5SUM:=9aa205cfd6b98e695ca8e9ae6d1bcb6b
|
|
+endef
|
|
+$(eval $(call Download,ath10k-firmware-qca988x-ct))
|
|
+
|
|
+
|
|
define Package/ath10k-firmware-qca99x0
|
|
$(Package/ath10k-firmware-default)
|
|
TITLE:=ath10k firmware for QCA99x0 devices
|
|
@@ -79,6 +99,16 @@ define Package/ath10k-firmware-qca988x/install
|
|
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
|
|
endef
|
|
|
|
+define Package/ath10k-firmware-qca988x-ct/install
|
|
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
|
|
+ $(INSTALL_DATA) \
|
|
+ $(PKG_BUILD_DIR)/QCA988X/board.bin \
|
|
+ $(1)/lib/firmware/ath10k/QCA988X/hw2.0/
|
|
+ $(INSTALL_DATA) \
|
|
+ $(DL_DIR)/$(QCA988X_CT_FIRMWARE_FILE) \
|
|
+ $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
|
|
+endef
|
|
+
|
|
define Package/ath10k-firmware-qca6174/install
|
|
$(INSTALL_DIR) $(1)/lib/firmware/ath10k
|
|
$(CP) $(PKG_BUILD_DIR)/QCA6174 $(1)/lib/firmware/ath10k/
|
|
@@ -98,5 +128,6 @@ define Package/ath10k-firmware-qca99x0/install
|
|
endef
|
|
|
|
$(eval $(call BuildPackage,ath10k-firmware-qca988x))
|
|
+$(eval $(call BuildPackage,ath10k-firmware-qca988x-ct))
|
|
$(eval $(call BuildPackage,ath10k-firmware-qca99x0))
|
|
$(eval $(call BuildPackage,ath10k-firmware-qca6174))
|
|
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
|
|
index 30da1cf..cd8d670 100644
|
|
--- a/package/kernel/mac80211/Makefile
|
|
+++ b/package/kernel/mac80211/Makefile
|
|
@@ -247,7 +247,7 @@ define KernelPackage/ath10k
|
|
$(call KernelPackage/mac80211/Default)
|
|
TITLE:=Atheros 802.11ac wireless cards support
|
|
URL:=https://wireless.wiki.kernel.org/en/users/Drivers/ath10k
|
|
- DEPENDS+= @PCI_SUPPORT +kmod-ath +@DRIVER_11N_SUPPORT +@DRIVER_11W_SUPPORT +@KERNEL_RELAY +ath10k-firmware-qca988x
|
|
+ DEPENDS+= @PCI_SUPPORT +kmod-ath +@DRIVER_11N_SUPPORT +@DRIVER_11W_SUPPORT +@KERNEL_RELAY
|
|
FILES:= \
|
|
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath10k/ath10k_core.ko \
|
|
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
|