e773f686c9
Caused by a broken backport. Fixes #689
54 lines
2.2 KiB
Diff
54 lines
2.2 KiB
Diff
From: Sven Eckelmann <sven.eckelmann@open-mesh.com>
|
|
Date: Sat, 9 Apr 2016 10:26:11 +0000
|
|
Subject: ar71xx: create profile and build image for the OpenMesh OM5P-AC board
|
|
|
|
Signed-off-by: Sven Eckelmann <sven.eckelmann@open-mesh.com>
|
|
|
|
Backport of r49148
|
|
|
|
Forwarded: https://patchwork.ozlabs.org/patch/624198/
|
|
|
|
diff --git a/target/linux/ar71xx/generic/profiles/openmesh.mk b/target/linux/ar71xx/generic/profiles/openmesh.mk
|
|
index 06cf135..64aaa24 100644
|
|
--- a/target/linux/ar71xx/generic/profiles/openmesh.mk
|
|
+++ b/target/linux/ar71xx/generic/profiles/openmesh.mk
|
|
@@ -27,6 +27,17 @@ endef
|
|
|
|
$(eval $(call Profile,OM5P))
|
|
|
|
+define Profile/OM5PAC
|
|
+ NAME:=OpenMesh OM5P-AC
|
|
+ PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog ath10k-firmware-qca988x
|
|
+endef
|
|
+
|
|
+define Profile/OM5PAC/Description
|
|
+ Package set optimized for the OpenMesh OM5P-AC.
|
|
+endef
|
|
+
|
|
+$(eval $(call Profile,OM5PAC))
|
|
+
|
|
define Profile/MR600
|
|
NAME:=OpenMesh MR600
|
|
PACKAGES:=kmod-ath9k om-watchdog
|
|
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
|
|
index 0ebb7dc..0cf1df1 100644
|
|
--- a/target/linux/ar71xx/image/Makefile
|
|
+++ b/target/linux/ar71xx/image/Makefile
|
|
@@ -2043,6 +2043,7 @@ $(eval $(call SingleProfile,Netgear,64kraw,WPN824N,wpn824n,WPN824N,ttyS0,115200,
|
|
|
|
$(eval $(call SingleProfile,OpenMesh,squashfs-only,OM2P,om2p,,,,OM2P))
|
|
$(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5P,om5p,,,,OM5P))
|
|
+$(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5PAC,om5pac,,,,OM5PAC))
|
|
$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR600,mr600,,,,MR600))
|
|
$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR900,mr900,,,,MR900))
|
|
$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR1750,mr1750,,,,MR1750))
|
|
@@ -2139,7 +2140,7 @@ $(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
|
|
$(eval $(call MultiProfile,DIR615IX,DIR615I1 DIR615I3))
|
|
$(eval $(call MultiProfile,AP136,AP136_010 AP136_020))
|
|
$(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
|
|
-$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900 MR1750))
|
|
+$(eval $(call MultiProfile,OPENMESH,OM2P OM5P OM5PAC MR600 MR900 MR1750))
|
|
$(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
|
|
$(eval $(call MultiProfile,TLMR3220,TLMR3220V1))
|
|
$(eval $(call MultiProfile,TLMR3420,TLMR3420V1))
|