b41f805316
6c3e16055a kernel: backport ksmbd security fix ZDI-22-1690 275c51bf40 Revert "image-commands.mk: Be consistent in command invocation" fec4fb3a56 sunxi: remove frequency for NanoPi R1 51a763ab0f arm-trusted-firmware-sunxi: drop CPE ID 377d805887 trusted-firmware-a.mk: use correct CPE ID f30414c56d kernel: bump 5.10 to 5.10.160 47ac52a7c4 ath79: image: don't depend on other COMPILE targets da79da3ac1 image: fix device profile specific COMPILE targets 9aa95bbebb rules: fix broken commitcount on alpine system fcff234fd8 image-commands.mk: Be consistent in command invocation be7b97d873 sunxi: fix typo in device packages for MarsBoard A10 709351bf32 kernel: Make KERNEL_MAKEOPTS recursively expanded 3b066a6581 lantiq: vr9: include usb driver for fritz 7430 39dcfcd987 wolfssl: fix build with /dev/crypto e51f3a22aa toolchain: Update glibc 2.34 to recent HEAD 298d2d0412 Revert "mbedtls: import patch to fix illegal instruction on mpc85xx" 3de4572ed3 tools/ccache: fix build with musl and gcc 12 8e43a44f08 rpcd: update to latest Git HEAD f43ceb60d5 iwinfo: update to latest Git HEAD 31baecb70e iwinfo: update to the latest version f34c4a950e iwinfo: update to the latest version 9b7a3e1a5e iwinfo: update to the latest version ce881873c0 kernel: add missing dependency to KERNEL_RPI_AXIPERF 7ccb4c6651 kernel: add missing symbol for bcm27xx b18a0d0b92 generic: add support for EON EN25QX128A spi nor flash d909fb1d3b kernel: bump 5.10 to 5.10.159 e5cec69484 kernel: bump 5.10 to 5.10.158 3a58bda06b kernel: bump 5.10 to 5.10.157 ee2341cac6 kernel: add symbol in generic config for 5.10.157 bc64ca15d4 kernel: kmod-net-rtl8192su: Remove package b1204ce28c umbim: Allow roaming and partner connections 15bc6b23c7 kernel: further cleanup of xfrm[4|6]_mode* 6e396eff1a kernel: remove handling of xfrm[4|6]_mode_* modules 78fc12ddd0 kernel: fix typo for tegra crypto-sha1 module 4408f7d564 kernel: add kmod-btsdio package 6b2c445b88 kernel: remove CONFIG_MMC_BLOCK_BOUNCE aef33ab13a ath79: fix Teltonika RUT230 v1 MAC assignment
31 lines
1.2 KiB
Diff
31 lines
1.2 KiB
Diff
From: David Bauer <mail@david-bauer.net>
|
|
Date: Tue, 5 Jul 2022 23:49:31 +0200
|
|
Subject: lantiq-xrx200: make DSA images swconfig upgradable
|
|
|
|
diff --git a/target/linux/lantiq/image/tp-link.mk b/target/linux/lantiq/image/tp-link.mk
|
|
index 756105b94c7f844439132ab57837c9ac87d231ca..5563968de9ab3f491fa89d755fcc6e6fff79948f 100644
|
|
--- a/target/linux/lantiq/image/tp-link.mk
|
|
+++ b/target/linux/lantiq/image/tp-link.mk
|
|
@@ -1,7 +1,7 @@
|
|
DEVICE_VARS += TPLINK_FLASHLAYOUT TPLINK_HWID TPLINK_HWREV TPLINK_HWREVADD TPLINK_HVERSION
|
|
|
|
define Device/dsa-migration
|
|
- DEVICE_COMPAT_VERSION := 1.1
|
|
+ DEVICE_COMPAT_VERSION := 1.0
|
|
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
|
|
endef
|
|
|
|
diff --git a/target/linux/lantiq/image/vr9.mk b/target/linux/lantiq/image/vr9.mk
|
|
index deea3996670fcef6d2a546373425c4ca5d92734b..d23b80e94e5548ccb19738f22c29c75fa19ab1e7 100644
|
|
--- a/target/linux/lantiq/image/vr9.mk
|
|
+++ b/target/linux/lantiq/image/vr9.mk
|
|
@@ -1,7 +1,7 @@
|
|
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
|
|
|
|
define Device/dsa-migration
|
|
- DEVICE_COMPAT_VERSION := 1.1
|
|
+ DEVICE_COMPAT_VERSION := 1.0
|
|
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
|
|
endef
|
|
|