2a3a0e32d5
3960c220da OpenWrt v22.03.5: revert to branch defaults 863f769b75 OpenWrt v22.03.5: adjust config defaults 5f15225c1e ramips: reduce Archer AX23 / MR70X SPI-frequency c1ccae54ce ccache: update to 4.6.3 80653f0c07 tools/ccache: update to 4.6.2 eeff8b3be1 tools/ccache: update to 4.6.1 31b1366bc6 ramips: fix lzma-loader for buffalo_WSR_600DHP bf81a92171 ath79: create Aruba AP-105 APBoot compatible image b6cbab1ad7 openssl: fix CVE-2023-464 and CVE-2023-465
116 lines
3.6 KiB
Diff
116 lines
3.6 KiB
Diff
From: David Bauer <mail@david-bauer.net>
|
|
Date: Tue, 15 Nov 2022 15:25:40 +0100
|
|
Subject: ath79: combine OCEDO dual firmware-partitions
|
|
|
|
In order to maximize the available space on OCEDO boards using a
|
|
dual-image partition layout, combine the two OS partitions into a single
|
|
partition.
|
|
|
|
This allows users to access more usable space for additional packages.
|
|
|
|
Don't limit the usable image size to the size of a single OS partition.
|
|
The initial installation has to be done with an older version of OpenWrt
|
|
in case the generated image exceeds the space of a single OS
|
|
partition in the future.
|
|
|
|
Signed-off-by: David Bauer <mail@david-bauer.net>
|
|
(cherry picked from commit eded295cd7fd53bfa5afcb67a1b91cfda0523ba6)
|
|
|
|
diff --git a/target/linux/ath79/dts/ar9344_ocedo_raccoon.dts b/target/linux/ath79/dts/ar9344_ocedo_raccoon.dts
|
|
index 0bbeb2b533b3fbbdcce53e094412d459ee762d85..3ecd20e2aa8fe04164cddbc84e0eb800e049c011 100644
|
|
--- a/target/linux/ath79/dts/ar9344_ocedo_raccoon.dts
|
|
+++ b/target/linux/ath79/dts/ar9344_ocedo_raccoon.dts
|
|
@@ -91,15 +91,10 @@
|
|
};
|
|
|
|
partition@50000 {
|
|
+ /* Dual-Flash layout combined */
|
|
compatible = "denx,uimage";
|
|
label = "firmware";
|
|
- reg = <0x050000 0x740000>;
|
|
- };
|
|
-
|
|
- partition@790000 {
|
|
- label = "vendor";
|
|
- reg = <0x790000 0x740000>;
|
|
- read-only;
|
|
+ reg = <0x050000 0xe80000>;
|
|
};
|
|
|
|
partition@ed0000 {
|
|
diff --git a/target/linux/ath79/dts/qca9558_ocedo_koala.dts b/target/linux/ath79/dts/qca9558_ocedo_koala.dts
|
|
index 66f8c6589b20221edc41a2f882b28229ff8633b9..de9e1bc19c4d03707f5b921ee5e9fe7422f461bb 100644
|
|
--- a/target/linux/ath79/dts/qca9558_ocedo_koala.dts
|
|
+++ b/target/linux/ath79/dts/qca9558_ocedo_koala.dts
|
|
@@ -88,15 +88,10 @@
|
|
};
|
|
|
|
partition@50000 {
|
|
+ /* Dual-Flash layout combined */
|
|
compatible = "denx,uimage";
|
|
label = "firmware";
|
|
- reg = <0x050000 0x740000>;
|
|
- };
|
|
-
|
|
- partition@790000 {
|
|
- label = "vendor";
|
|
- reg = <0x790000 0x740000>;
|
|
- read-only;
|
|
+ reg = <0x050000 0xe80000>;
|
|
};
|
|
|
|
partition@ed0000 {
|
|
diff --git a/target/linux/ath79/dts/qca9558_ocedo_ursus.dts b/target/linux/ath79/dts/qca9558_ocedo_ursus.dts
|
|
index 2dc4c07e918c50eb522100eb7f72c8804d5ba5fb..f8b3681bb7f143a498d5cb64897af335b970c43b 100644
|
|
--- a/target/linux/ath79/dts/qca9558_ocedo_ursus.dts
|
|
+++ b/target/linux/ath79/dts/qca9558_ocedo_ursus.dts
|
|
@@ -59,15 +59,10 @@
|
|
};
|
|
|
|
partition@50000 {
|
|
+ /* Dual-Flash layout combined */
|
|
compatible = "denx,uimage";
|
|
label = "firmware";
|
|
- reg = <0x050000 0x740000>;
|
|
- };
|
|
-
|
|
- partition@790000 {
|
|
- label = "vendor";
|
|
- reg = <0x790000 0x740000>;
|
|
- read-only;
|
|
+ reg = <0x050000 0xe80000>;
|
|
};
|
|
|
|
partition@ed0000 {
|
|
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
|
|
index f1542e4e38f7540dd9facf4c40f0b271b9ea1e45..87d01a42eda274f9197f3382d955b87ecf615f7d 100644
|
|
--- a/target/linux/ath79/image/generic.mk
|
|
+++ b/target/linux/ath79/image/generic.mk
|
|
@@ -1803,7 +1803,7 @@ define Device/ocedo_koala
|
|
DEVICE_MODEL := Koala
|
|
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
|
|
SUPPORTED_DEVICES += koala
|
|
- IMAGE_SIZE := 7424k
|
|
+ IMAGE_SIZE := 14848k
|
|
endef
|
|
TARGET_DEVICES += ocedo_koala
|
|
|
|
@@ -1811,7 +1811,7 @@ define Device/ocedo_raccoon
|
|
SOC := ar9344
|
|
DEVICE_VENDOR := Ocedo
|
|
DEVICE_MODEL := Raccoon
|
|
- IMAGE_SIZE := 7424k
|
|
+ IMAGE_SIZE := 14848k
|
|
endef
|
|
TARGET_DEVICES += ocedo_raccoon
|
|
|
|
@@ -1820,7 +1820,7 @@ define Device/ocedo_ursus
|
|
DEVICE_VENDOR := Ocedo
|
|
DEVICE_MODEL := Ursus
|
|
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
|
|
- IMAGE_SIZE := 7424k
|
|
+ IMAGE_SIZE := 14848k
|
|
endef
|
|
TARGET_DEVICES += ocedo_ursus
|
|
|