c3be82f6c8
83b714a27f musl: fix locking synchronization bug f99b1d1d92 rpcd: update to latest openwrt-19.07 Git HEAD 92bd395b04 Revert "rpcd: update to latest Git HEAD" adf5d753ef rpcd: update to latest Git HEAD 9b48375c7e libubox: update to the latest version a4e8eca03e libubox: update to the latest master 498f1f4f5d ramips: gsw_mt7621: disable PORT 5 MAC RX/TX flow control by default d8d1956a80 hostapd: backport wolfssl bignum fixes ab7e9754df ucert: update to latest git HEAD bc0c2db2a3 brcm47xx: disable Netgear WNR2000 v2 by default 059db419d7 squashfs: Fix compile with GCC 10 97b522a1f9 usign: update to latest git HEAD 942262f9c8 usign: update to latest Git HEAD 6a89098935 ath79: add support for TP-Link TL-WA901ND v4 and v5 a6f70f2e97 ath79: add support for TP-Link TL-WA701ND/730RE/801ND/901ND v1 8c6c488e9e ath79: add support for TP-Link TL-WR940N v6 36d4140517 ath79: add support for TP-Link TL-WA830RE v1 7187826b8b ath79: reorganize DTSI for ar7240 TP-Link devices d4092eac1f ath79: migrate TP-Link TL-MR3420v2 to ath79 24cfd961d9 ath79: add support for TP9343-based TP-Link TL-WR94x devices 7de43d66ff generic: platform/mikrotik: disambiguate SPDX-License-Identifier 84154574c8 ramips: drop non-existant ralink,port-map for Ravpower WD03 af667c73c5 bcm63xx: mask interrupts on init d1ce73677c bcm63xx: periph_intc: report effective affinity 1d40c8a9f2 bcm63xx: ext_intc: fix warning 65f2fae911 bcm63xx: periph_intc: fix warning b2c9f82eb4 bcm63xx: redboot: fix warning a2a3ac9f51 bcm63xx: bcm6362: fix pinctrl bug 6c96ecf3b4 bcm63xx: refresh kernel config c3e3802a8e OpenWrt v19.07.3: revert to branch defaults f3f38f40da OpenWrt v19.07.3: adjust config defaults 85e04e9f46 generic: platform/mikrotik: fix LZOR support 4cd9ae41c5 libjson-c: backport security fixes 6ffd4d8a4d ar71xx: remove hard-coded folder name from Mikrotik RB upgrade d2ee15ef76 fstools: blockd: fix segfault triggered by non-autofs mounts 4cd44e5dc7 ar71xx: mikrotik: mach-rbspi.c remove wlan id 3fecb06fb1 ar71xx: mikrotik: bypass id check in __rb_get_wlan_data() b36aa168d8 ar71xx: mikrotik: ath10k: use new sysfs driver fa2369e59b generic: platform/mikrotik: support LZOR encoding 612b64e6c4 ar71xx: enable mikrotik platform driver 511859de9b generic: mikrotik platform build bits ddae86cc69 generic: routerboot sysfs platform driver 2efcfb1d1a kernel: bump 4.14 to 4.14.180 ecea10f2b9 ath79: dts: add missing 'serial0' alias for TP-Link TL-MR3040v2
62 lines
2.7 KiB
Diff
62 lines
2.7 KiB
Diff
From: Jan Alexander <jan@nalx.net>
|
|
Date: Tue, 31 Mar 2020 21:50:28 +0200
|
|
Subject: ath79: enable GL-AR750S NOR variant from master
|
|
|
|
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
|
|
index 9b9bc8a7fc15300247bceeb431ab3ae8d3ac47e6..da45b40086c0cb0011c1db6b89ae75b981fcc9b7 100755
|
|
--- a/target/linux/ath79/base-files/etc/board.d/02_network
|
|
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
|
|
@@ -151,7 +151,7 @@ ath79_setup_interfaces()
|
|
etactica,eg200)
|
|
ucidef_set_interface_lan "eth0" "dhcp"
|
|
;;
|
|
- glinet,gl-ar750s)
|
|
+ glinet,gl-ar750s-nor)
|
|
ucidef_add_switch "switch0" \
|
|
"0@eth0" "2:lan:2" "3:lan:1" "1:wan"
|
|
;;
|
|
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
index d93e6dcd71ab19c53905daa41e95cc4fc614f114..c917f38211d0b246f064dba4b7feefecf61f5856 100644
|
|
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
@@ -117,7 +117,7 @@ case "$FIRMWARE" in
|
|
ath10kcal_extract "art" 20480 2116
|
|
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
|
|
;;
|
|
- glinet,gl-ar750s)
|
|
+ glinet,gl-ar750s-nor)
|
|
ath10kcal_extract "art" 20480 2116
|
|
ath10kcal_patch_mac $(macaddr_add $(mtd_get_mac_binary art 0) +1)
|
|
;;
|
|
diff --git a/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
|
|
index 0145a24fbae2cdbe6fb6445607795af6b792352d..ebecb8cc776091ec019638589cb88159345d367f 100644
|
|
--- a/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
|
|
+++ b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
|
|
@@ -7,8 +7,8 @@
|
|
#include "qca956x.dtsi"
|
|
|
|
/ {
|
|
- compatible = "glinet,gl-ar750s", "qca,qca9563";
|
|
- model = "GL.iNet GL-AR750S";
|
|
+ compatible = "glinet,gl-ar750s-nor", "qca,qca9563";
|
|
+ model = "GL.iNet GL-AR750S (NOR)";
|
|
|
|
chosen {
|
|
bootargs = "console=ttyS0,115200n8";
|
|
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
|
|
index 55053be34f11f0df982c85f94c9180fdba9ff221..892ef10f870e347c8a1509cecd35bce4b5e98bee 100644
|
|
--- a/target/linux/ath79/image/generic.mk
|
|
+++ b/target/linux/ath79/image/generic.mk
|
|
@@ -403,9 +403,9 @@ define Device/glinet_gl-ar750s
|
|
DEVICE_TITLE := GL.iNet GL-AR750S
|
|
DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct block-mount
|
|
IMAGE_SIZE := 16000k
|
|
- SUPPORTED_DEVICES += gl-ar750s
|
|
+ SUPPORTED_DEVICES += gl-ar750s glinet,gl-ar750s-nor
|
|
endef
|
|
-#TARGET_DEVICES += glinet_gl-ar750s
|
|
+TARGET_DEVICES += glinet_gl-ar750s
|
|
|
|
define Device/glinet_gl-x750
|
|
ATH_SOC := qca9531
|