5b7d01b427 iwinfo: update to latest HEAD 39aaec62ca hostapd: refresh patches e2030fcfa7 hostapd: add ubus link-measurements notifications 1a2940f68e hostapd: add ubus method for requesting link measurements b4a9597154 hostapd: add support for enabling link measurements 5a18028c69 iwinfo: update to latest HEAD b519d76276 iwinfo: update to latest Git head 01cc5e195d iwinfo: update to latest Git HEAD 44781b265c iwinfo: update to the latest version f7c445aa7d iwinfo: update to the latest version 75cbd8de00 wolfssl: fix compilation with /dev/crypto 1418439da9 kernel: add missing config symbols 39f1815b3e mac80211: fix QCA9561 PA bias 1769e3162e ramips: mt7620: disable SOC VLANs for external switches 30e47fb1e4 ramips: mt7620: ethernet: use more macros and bump version 3f976d0225 ramips: mt7620: fix RGMII TXID PHY mode 6685eb29e5 ramips: mt7620: add ephy-disable option to switch driver 47db830b82 ramips: mt7620: move mt7620_mdio_mode() to ethernet driver 6876465875 ramips: mt7620: use DTS to set PHY base address for external PHYs 5d7805c78b ramips: mt7620: allow both internal and external PHYs 01bbed7444 ramips: mt7620: fix ethernet driver GMAC port init 6491212ea7 ramips: mt7620: remove useless GMAC nodes a14c2d409c ramips: mt7620: simplify DTS properties for GMAC c652a06eef ramips: mt7620: enable autonegotiation for all ports 08ec622c46 ramips: make PHY initialization more descriptive 4123f177f9 ramips: add support for the Wavlink WL-WN579X3 92af15077f ramips: split Youku YK1 to YK-L1 and YK-L1c 55f8eb84d2 ramips: improve pinctrl for Youku YK-L1 92489b4f82 ramips: speed up spi frequency for Youku YK-L1 bea1891182 ramips: remove obsolete mx25l25635f compatible hack 6c44b157e5 mvebu: kernel: enable CONFIG_BLK_DEV_NVME f0f9b7ac5c OpenWrt v21.02.3: revert to branch defaults 42a15ca378 OpenWrt v21.02.3: adjust config defaults 1d4dea6d4f ath79: Move TPLink WPA8630Pv2 to ath79-tiny target 41a97c2074 bcm27xx: add AMP2 to HifiBerry DAC+ / DAC+ Pro package 9a765554f4 ath79: add support for MikroTik RouterBOARD mAP lite 2cc9ee8000 ath79: add support for Yuncore A930 06874171d1 ath79: add support for Yuncore XD3200 c5ef62a218 wolfssl: bump to 5.2.0 99b00edf35 mac80211: Update to version 5.10.110-1 9132344444 bpftools: fix feature override for masking clang 169c9e3a88 ramips: fix reboot for remaining 32 MB boards 39bf2aee0e kernel: bump 5.4 to 5.4.188 3008f1f441 imagebuilder: fix broken image generation with external targets
152 lines
5.3 KiB
Diff
152 lines
5.3 KiB
Diff
From: Sven Eckelmann <sven@narfation.org>
|
|
Date: Mon, 23 Nov 2020 13:41:34 +0100
|
|
Subject: ath79: Add support for OpenMesh A40
|
|
|
|
Device specifications:
|
|
======================
|
|
|
|
* Qualcomm/Atheros QCA9558 ver 1 rev 0
|
|
* 720/600/240 MHz (CPU/DDR/AHB)
|
|
* 128 MB of RAM
|
|
* 16 MB of SPI NOR flash
|
|
- 2x 7 MB available; but one of the 7 MB regions is the recovery image
|
|
* 2T2R 2.4 GHz Wi-Fi (11n)
|
|
* 2T2R 5 GHz Wi-Fi (11ac)
|
|
* multi-color LED (controlled via red/green/blue GPIOs)
|
|
* 1x GPIO-button (reset)
|
|
* external h/w watchdog (enabled by default))
|
|
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
|
|
* 2x ethernet
|
|
- eth0
|
|
+ Label: Ethernet 1
|
|
+ AR8035 ethernet PHY (RGMII)
|
|
+ 10/100/1000 Mbps Ethernet
|
|
+ 802.3af POE
|
|
+ used as WAN interface
|
|
- eth1
|
|
+ Label: Ethernet 2
|
|
+ AR8035 ethernet PHY (SGMII)
|
|
+ 10/100/1000 Mbps Ethernet
|
|
+ used as LAN interface
|
|
* 1x USB
|
|
* internal antennas
|
|
|
|
Flashing instructions:
|
|
======================
|
|
|
|
Various methods can be used to install the actual image on the flash.
|
|
Two easy ones are:
|
|
|
|
ap51-flash
|
|
----------
|
|
|
|
The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
|
|
used to transfer the image to the u-boot when the device boots up.
|
|
|
|
initramfs from TFTP
|
|
-------------------
|
|
|
|
The serial console must be used to access the u-boot shell during bootup.
|
|
It can then be used to first boot up the initramfs image from a TFTP server
|
|
(here with the IP 192.168.1.21):
|
|
|
|
setenv serverip 192.168.1.21
|
|
setenv ipaddr 192.168.1.1
|
|
tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr
|
|
|
|
The actual sysupgrade image can then be transferred (on the LAN port) to the
|
|
device via
|
|
|
|
scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/
|
|
|
|
On the device, the sysupgrade must then be started using
|
|
|
|
sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin
|
|
|
|
Signed-off-by: Sven Eckelmann <sven@narfation.org>
|
|
(cherry picked from commit 9a172797e593c061f6759a37eaeba2956ad8d72f)
|
|
|
|
diff --git a/package/boot/uboot-envtools/files/ath79 b/package/boot/uboot-envtools/files/ath79
|
|
index 363a0f9a581d16dff4673019b7706b505f74d11c..e75edff16eb40c7950cfed7767144becae6b67b1 100644
|
|
--- a/package/boot/uboot-envtools/files/ath79
|
|
+++ b/package/boot/uboot-envtools/files/ath79
|
|
@@ -49,6 +49,7 @@ netgear,wnr2200-16m|\
|
|
netgear,wnr612-v2|\
|
|
ocedo,koala|\
|
|
ocedo,raccoon|\
|
|
+openmesh,a40|\
|
|
openmesh,a60|\
|
|
openmesh,mr600-v1|\
|
|
openmesh,mr600-v2|\
|
|
diff --git a/target/linux/ath79/dts/qca9558_openmesh_a40.dts b/target/linux/ath79/dts/qca9558_openmesh_a40.dts
|
|
new file mode 100644
|
|
index 0000000000000000000000000000000000000000..d2b817031a9db6846de0632a64962a0197fa2c6f
|
|
--- /dev/null
|
|
+++ b/target/linux/ath79/dts/qca9558_openmesh_a40.dts
|
|
@@ -0,0 +1,8 @@
|
|
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
|
|
+
|
|
+#include "qca9558_openmesh_a60.dtsi"
|
|
+
|
|
+/ {
|
|
+ compatible = "openmesh,a40", "qca,qca9558";
|
|
+ model = "OpenMesh A40";
|
|
+};
|
|
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
|
|
index eb6068180cb2dd3aac8a455fdbfb29a91d475699..6d9dd22b99fc90b197189b4bae6a457ec52e17a9 100755
|
|
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
|
|
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
|
|
@@ -172,6 +172,7 @@ ath79_setup_interfaces()
|
|
comfast,cf-e120a-v3|\
|
|
comfast,cf-e314n-v2|\
|
|
compex,wpj531-16m|\
|
|
+ openmesh,a40|\
|
|
openmesh,a60|\
|
|
openmesh,om2p-v4|\
|
|
openmesh,om2p-hs-v4|\
|
|
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
index 9e1f660cbcf47b1e6194fd10be051daba59b5fe3..69e643f735476d68947faf29d0dc4cdf0959950c 100644
|
|
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
|
|
@@ -100,6 +100,7 @@ case "$FIRMWARE" in
|
|
caldata_extract "art" 0x5000 0x844
|
|
ath10k_patch_mac $(mtd_get_mac_binary art 0xc)
|
|
;;
|
|
+ openmesh,a40|\
|
|
openmesh,a60|\
|
|
openmesh,mr1750-v1|\
|
|
openmesh,mr1750-v2|\
|
|
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
|
|
index f7862bb032fbce56be77e9db8ae2e37bf5da30ea..e979c11bb91cb20fd4168b8921499f03572d3512 100644
|
|
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
|
|
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
|
|
@@ -65,6 +65,7 @@ platform_do_upgrade() {
|
|
jjplus,ja76pf2)
|
|
redboot_fis_do_upgrade "$1" linux
|
|
;;
|
|
+ openmesh,a40|\
|
|
openmesh,a60|\
|
|
openmesh,mr600-v1|\
|
|
openmesh,mr600-v2|\
|
|
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
|
|
index ed13ad231736d5da1a412162892139193a9523ab..26b12945459c10fa5eb251509836e0c96a39d546 100644
|
|
--- a/target/linux/ath79/image/generic.mk
|
|
+++ b/target/linux/ath79/image/generic.mk
|
|
@@ -1640,6 +1640,16 @@ define Device/openmesh_common_256k
|
|
openmesh-image ce_type=$$$$(OPENMESH_CE_TYPE) | append-metadata
|
|
endef
|
|
|
|
+define Device/openmesh_a40
|
|
+ $(Device/openmesh_common_64k)
|
|
+ SOC := qca9558
|
|
+ DEVICE_MODEL := A40
|
|
+ DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct kmod-usb2
|
|
+ OPENMESH_CE_TYPE := A60
|
|
+ SUPPORTED_DEVICES += a40
|
|
+endef
|
|
+TARGET_DEVICES += openmesh_a40
|
|
+
|
|
define Device/openmesh_a60
|
|
$(Device/openmesh_common_64k)
|
|
SOC := qca9558
|